Dependency on Java 1.4.x SDK