b54 requires glibc 2.5 or later on 64 bit linux