--libraries doesn't work