jdk minimum version supported by jmaki?