v1.8.1 issues in eclipse