Does JXLayer work with JDK 5 or 6?