moving users from 1.4.2 to 1.5 seamlessly