Have you switched your development to J2SE 5.0 yet?