Earliest J2SE version that your next app must still support: