Using JSR 105 with JDK 1.4 or 1.5