Porting small library from Java 5.0 to Java 1.4 - could it be any harder?