Do you know which version of MMAPI you are using?