Skip to main content

Re: 404 on pkg repository

No replies
snjezana
Offline
Joined: 2005-02-15
Points: 0

This is strange - there should be another level denoting OS type between those two slashes, in your case this:

http://pkg.glassfish.org/v3/stable/windows/catalog/0

I believe that stripping one slash brings you back to the base repository URL, but that one then redirects to SunOS content repository, although it should not matter in the case of hibernate package which is platform independent.

If you had this working on the same platform before, something must have happened to server side redirect configuration. On the other hand, this seems to be working for me on Windows 7 right now, so it is also possible that Windows 2008 returns something unexpected as OS name value.

As workaround you could try modifying the value of origin variable for [authority_stable.glassfish.org] in .org.opensolaris,pkg/cfg_cache file from http://pkg.glassfish.org/v3/stable/ to http://pkg.glassfish.org/v3/stable/windows/

HTH...

Snjezana

----- Original Message -----
From: ljnelson@gmail.com
To: users@glassfish.java.net
Sent: Friday, February 1, 2013 3:56:15 PM GMT +01:00 Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
Subject: 404 on pkg repository

Hello; we're trying to install the Hibernate add-on today from a Windows 2008 R2 installation and the pkg repository is giving us 404 errors.

The URL from the bowels of pkg (as it reports it) is: http://pkg.glassfish.org/v3/stable//catalog/0

Note the double slash before "catalog"; if I strip it back to one, I can see the listing. But the double slash is present in what pkg is looking for.

It looks from the "powered by" footer that perhaps the package repository recently got upgraded or moved in case that helps.

Best,
Laird

--
http://about.me/lairdnelson

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
ljnelson
Offline
Joined: 2003-08-04
Points: 0

On Fri, Feb 1, 2013 at 7:10 AM, Snjezana Sevo-Zenzerovic <
> wrote:

> If you had this working on the same platform before, something must have
> happened to server side redirect configuration.
>

Yes, we've had this working before.

> On the other hand, this seems to be working for me on Windows 7 right now,
> so it is also possible that Windows 2008 returns something unexpected as OS
> name value.
>

Maybe, but surely this is a common platform?

> As workaround you could try modifying the value of origin variable for [
> authority_stable.glassfish.org] in .org.opensolaris,pkg/cfg_cache file
> from http://pkg.glassfish.org/v3/stable/ to
> http://pkg.glassfish.org/v3/stable/windows/
>

Thanks, we'll give it a shot!

Best,
Laird

--
http://about.me/lairdnelson