Skip to main content

Can't start a domain with the command

2 replies [Last post]
Maxxx50
Offline
Joined: 2013-01-13

Hello,

I try to use Glassfish 3.1.1, but i have a little problem with asadmin commands. First time I installed glassfish, everything worked until I reinstalled it after having a problem with the database.
And now when i try to start a domain with the command "asadmin start-domain domain1" i have this message :

C:\Users\Max>asadmin start-domain domain1;
CLASSPATH= D:\Outils-de-dev\Glassfish\bin\..\glassfish\modules\admin-cli.jar
Commands: [start-domain, domain1;]
asadmin extension directory: D:\Outils-de-dev\Glassfish\glassfish\lib\asadmin
Prepare
Process program options
Parsing program options
Parse command options
params: {}
operands: [domain1;]
Prevalidate command options
Inject command options
Validate command options
There is no such domain directory: D:\Outils-de-dev\Glassfish\glassfish\domains\
domain1;
Command start-domain failed.

I didn't found the same problem on the web, i hope someone can tell me the issue.
For information, I'm running on windows 7 64B, and using the JDK 7.0.9.

Thanks.

PS : Sorry for my bad english.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Maxxx50
Offline
Joined: 2013-01-13

Ahah, I think i was very tired yesterday, i just put a ";" at the end of the command ...

Thank you andreas_ernst, i'm sorry for wasting your time.

andreas_ernst
Offline
Joined: 2003-06-20

Go to the glassfish/bin directory and try to start asadmin from there.

Or download NetBeans 7.2.1 the full package with Glassfish in it. You can start and stop Glassfish with NetBeans.