Skip to main content

Postgresql schema does not exist error

No replies
ruddy32
Offline
Joined: 2013-01-08

Hi,
I have configure postgresql 8.4 database and check it by hand using the roles used for jdbc connection. While deploying the application on the server, I get this error :

[#|2013-01-08T15:55:28.037+0100|WARNING|glassfish3.1.2|org.eclipse.persistence.session.file:/opt/glassfish-3.1.2.2/glassfish/domains/domain1/applications/mcr/mcr-persistence-0.0.1-SNAPSHOT_jar/_mcrPersistence|_ThreadID=76;_ThreadName=Thread-2;|Local Exception Stack: 
Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.3.2.v20111125-r10461): org.eclipse.persistence.exceptions.DatabaseException
Internal Exception: org.postgresql.util.PSQLException: ERROR: schema "sc1" does not exist
  Position¬†: 32
Error Code: 0
Call: SELECT id, name, settings FROM sc1.tb1
Query: ReadAllQuery(referenceClass=Service sql="SELECT id, name, settings FROM sc1.tb1")

Before this log I have the following information :

[#|2013-01-08T08:41:52.059+0100|CONFIG|glassfish3.1.2|org.eclipse.persistence.session.file:/opt/glassfish-3.1.2.2/glassfish/domains/domain1/applications/myapp/web-0.0.1-SNAPSHOT_war/WEB-INF/lib/pers-0.0.1-SNAPSHOT.jar_pres.connection|_ThreadID=20;_ThreadName=Thread-2;|connecting(DatabaseLogin(
platform=>PostgreSQLPlatform
user name=> ""
connector=>JNDIConnector datasource name=>null
))|#]

[#|2013-01-08T08:41:52.060+0100|CONFIG|glassfish3.1.2|org.eclipse.persistence.session.file:/opt/glassfish-3.1.2.2/glassfish/domains/domain1/applications/myapp/web-admin-0.0.1-SNAPSHOT_war/WEB-INF/lib/pers-0.0.1-SNAPSHOT.jar_pres.connection|_ThreadID=20;_ThreadName=Thread-2;|Connected: jdbc:postgresql://localhost:5432/db1?loginTimeout=0&socketTimeout=0&prepareThreshold=5&unknownLength=2147483647&tcpkeepalive=false
User: myu
Database: PostgreSQL  Version: 8.4.14
Driver: PostgreSQL Native Driver  Version: PostgreSQL 8.4 JDBC4 (build 703)|#]

[#|2013-01-08T08:41:52.060+0100|CONFIG|glassfish3.1.2|org.eclipse.persistence.session.file:/opt/glassfish-3.1.2.2/glassfish/domains/domain1/applications/myapp/web-admin-0.0.1-SNAPSHOT_war/WEB-INF/lib/pers-0.0.1-SNAPSHOT.jar_pres.connection|_ThreadID=20;_ThreadName=Thread-2;|connecting(DatabaseLogin(
platform=>PostgreSQLPlatform
user name=> ""
connector=>JNDIConnector datasource name=>null
))|#]

I guess it might something wrong in the jdbc config. right?

Thanks