Skip to main content

Error You are running on JDK6 which comes with JAX-WS 2.1 API, but this tool requires JAX-WS 2.2

1 reply [Last post]
DeepikaChug
Offline
Joined: 2012-09-24
Points: 0

Hi,

I am new to this platform, while I am running an existing code, I get the following error :-

You are running on JDK6 which comes with JAX-WS 2.1 API, but this tool requires JAX-WS 2.2 API. Use the endorsed standards override mechanism (http://java.sun.com/javase/6/docs/technotes/guides/standards/), or set xendorsed="true" on .

Can you please tell where I can set the xendorsed value

Thanks,
Deepika

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
jungicz
Offline
Joined: 2004-08-17
Points: 0

Hi,

that messages gives you two options:

1) follow http://jax-ws.java.net/2.2.7/docs/ch04.html#running-on-jdk6

or

2) 'xendorsed' is one of wsgen/wsimport's options (in case of command line tool) or task attributes (in case of an ant task) - so find where this tool is called and set that option for it

HTH,
--lukas