Skip to main content

Web Service Client in Eclipse with GlassFish 3.1 and Apache Axis2

No replies
mihok
Offline
Joined: 2012-09-20
Points: 0

I've developed a web service in Eclipse that I am running on GlassFish 3.1. Everything works fine. I then created a simple client in Eclipse to invoke the service. I created a Java project and then did New->Other->Web Service Client and followed the prompts. Unfortunately, I found a bug in the Apache Axis 1.4 version that comes with the Java EE version of Eclipse that is preventing the service from working properly. As such, I need to update to Axis2. If I try to create a new Web Service Client in the same manner after updating, I am prompted for the server runtime and the web service runtime by Eclipse (see attached picture). I would like to select GlassFish 3.1 for the server runtime and Apache Axis2 for the web service runtime. Unfortunately, when I do I get the error “The Apache Axis2 Web service runtime in GlassFish 3.1 does not support the client project.” Does anyone know a way around this? Thank you very much for your assistance.

AttachmentSize
Web_Service_Error.png84.8 KB