Skip to main content

JMX connections not working

2 replies [Last post]
john_glynn
Offline
Joined: 2006-05-17
Points: 0

Hello Everyone.

I have two domains running 3.1.2.2. In one, I can connect to any instance with JConsole and in the other I can't. The only difference between the domains other than naming is that one is running on the standard admin port 4848 and the other is not. The second domain was created with --portbase=5000 due to existing port conflicts on that server. My question is are JMX connections still possible? And, if so, what other steps are needed to make it work?

Thanks.
JG

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
tmueller
Offline
Joined: 2005-10-31
Points: 0

Is jconsole running on the same system as GlassFish? If not, then
secure admin needs to be enabled in order to access the JMX port.

Tom

On 9/18/2012 1:53 PM, forums@java.net wrote:
> Hello Everyone. I have two domains running 3.1.2.2. In one, I can
> connect to
> any instance with JConsole and in the other I can't. The only difference
> between the domains other than naming is that one is running on the
> standard
> admin port 4848 and the other is not. The second domain was created with
> --portbase=5000 due to existing port conflicts on that server. My
> question is
> are JMX connections still possible? And, if so, what other steps are
> needed
> to make it work? Thanks. JG
>
> --
>
> [Message sent by forum member 'john_glynn']
>
> View Post: http://forums.java.net/node/890342
>
>

john_glynn
Offline
Joined: 2006-05-17
Points: 0

Yes secure admin is enabled. Remote access works perfectly on the domain at 4848 and not at all on the domain at 5048.