Skip to main content

why is domain1/docroot being searched?

No replies
rrlangly
Offline
Joined: 2012-06-25

I'm trying to access my app (uses struts) by 'localhost:8080/testapp/index.action' (or index.jsp) but I can see from the server.log its looking for index.jsp inside the domain1/docroot dir. If I go to this dir, I see my files are not there, but rather, they are under domain1/applications. I deployed my webapp using the localhost:4848 apps page.

Anyone see where I may be going wrong?

<br />
|-- META-INF<br />
|   |-- MANIFEST.MF<br />
|   `-- application.xml<br />
|-- WEB-INF<br />
|   |-- Test.jsp<br />
|   |-- classes<br />
|   |   |-- com<br />
|   |   |   `-- test<br />
|   |   |       `-- abc<br />
|   |   |           `-- app1<br />
|   |   |               `-- action<br />
|   |   |                   `-- TestAction.class<br />
|   |   |-- log4j.dtd<br />
|   |   |-- log4j.xml<br />
|   |   `-- struts.xml<br />
|   |-- index.jsp<br />
|   |-- lib<br />
|   |   |-- asm-3.3.jar<br />
|   |   |-- asm-commons-3.3.jar<br />
|   |   |-- asm-tree-3.3.jar<br />
|   |   |-- commons-fileupload-1.2.2.jar<br />
|   |   |-- commons-io-2.0.1.jar<br />
|   |   |-- commons-lang-2.4.jar<br />
|   |   |-- commons-lang3-3.1.jar<br />
|   |   |-- freemarker-2.3.19.jar<br />
|   |   |-- javassist-3.15.0-GA.jar<br />
|   |   |-- ognl-3.0.5.jar<br />
|   |   |-- struts2-core-2.3.4.jar<br />
|   |   `-- xwork-core-2.3.4.jar<br />
|   `-- web.xml<br />
|-- com<br />
|   `-- test<br />
|       `-- abc<br />
|           `-- app1<br />
|               `-- dao<br />
|                   `-- TestMessageStore.class<br />