Skip to main content

Build RIM source to fix touch bug

2 replies [Last post]
mmohsen_silverkey
Offline
Joined: 2012-01-11

I developed a blackberry application using the release LWUIT 1.5 with OSSigned4.7.jar, blackberry JDE 5.0 and Eclipse. It works OK except for touch devices in OS7 such as 9900. So I searched online and know that this fixed in SVN so I had to checkout the code and work in netbeans. I build the code at trunk/ui and it work OK. Now my problem is that when I build the code at trunk/port/RIM/UI_RIM, I had build errors such that can't find symbol BrowserField and a lot of other errors with the same can't find symbol.

Any help would be really appreciated

Thanks in advance

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
vprise
Offline
Joined: 2003-11-07

The trunk requires OS 5 for the touch version of the API and no longer supports OS 4.7 which is no longer supported by RIM (was only used on Storm 1.0 which was upgraded to 5.0).

mmohsen_silverkey
Offline
Joined: 2012-01-11

Thanks alot for your reply. I solved the issue by adding some imports statements