Skip to main content

Unable to get OSGi console working in Glassfish 3.1.1

1 reply [Last post]
rjdkolb
Offline
Joined: 2006-07-20
Points: 0

Hi there

I am following this tutorial for OSGi
http://netbeans.org/kb/docs/javaee/maven-osgiservice-cdi.html

It says I should install glassfish-osgi-gui add-on in Glassfish 3.1.1 and
restarted.
When I do this an restart I get a HTTP 404 when click on the "server (Admin
Server)" -> "OSGI Console"
(there is nothing deployed at http://localhost:8080/osgi/ and no errors in
the logs I can see)

Even got this log :
*[#|2011-11-29T08:33:54.858+0200|INFO|glassfish3.1.1|org.glassfish.osgihttp|_ThreadID=19;_ThreadName=Thread-6;|standardContext
=
StandardEngine[glassfish-web].StandardHost[__asadmin].StandardContext[/osgi]|#]
*

I've tried to install the other OSGi packages, but not luck.

Please help

thanks
Richard,

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
ss141213
Offline
Joined: 2005-03-30
Points: 0

Can you tell me which of the following links work for you?
http://localhost:8080/osgi/system/console/
http://localhost:4848/osgi/system/console/

Thanks,
Sahoo
On Tuesday 29 November 2011 12:18 PM, Richard Kolb wrote:
> Hi there
>
> I am following this tutorial for OSGi
> http://netbeans.org/kb/docs/javaee/maven-osgiservice-cdi.html
>
> It says I should install glassfish-osgi-gui add-on in Glassfish 3.1.1
> and restarted.
> When I do this an restart I get a HTTP 404 when click on the "server
> (Admin Server)" -> "OSGI Console"
> (there is nothing deployed at http://localhost:8080/osgi/ and no
> errors in the logs I can see)
>
> Even got this log :
> */[#|2011-11-29T08:33:54.858+0200|INFO|glassfish3.1.1|org.glassfish.osgihttp|_ThreadID=19;_ThreadName=Thread-6;|standardContext
> =
> StandardEngine[glassfish-web].StandardHost[__asadmin].StandardContext[/osgi]|#]/*
>
>
>
> I've tried to install the other OSGi packages, but not luck.
>
> Please help
>
> thanks
> Richard,
>