Skip to main content

Application Config problems - Newbie

2 replies [Last post]
Anonymous

Hey All,
I'm teaching myself Jave EE using the tutorials found on http://download.oracle.com/javaee/ . Unfortunately I've created a problem for myself that I seem unable to fix.

I have literally got to the first few steps of the "Your first cup Application" which involved setting up a web application and creating a page that says "15" and this is the error I am getting:

description The server encountered an internal error () that prevented it from fulfilling this request.
exception
javax.servlet.ServletException: PWC1391: Servlet.init() for servlet org.netbeans.rest.application.config.ApplicationConfig threw exception
root cause
com.sun.jersey.api.container.ContainerException: The ResourceConfig instance does not contain any root resource classes.

This error occurred when I refectories my only class from DukesAgeREsource to DukesAgeResource. I've restarted the project under a different name and it works fine, but if I delete the original project and create one of the same name the same error will appear. This makes me think it's something to do with a file related to the Glassfish server, but I have no idea really since I am just starting out!
I have done some searching and heard that it can be an error with a servlets being created, I've checked the sun-web.xml files and this doesn't seem the case. I have compared most files with a working new project and they seem identical in every way so I am at a lost for solutions.

Any help is appreciated.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
mathiaslin
Offline
Joined: 2009-02-13

Ran into the same issue, here's the answer to it:

http://forums.netbeans.org/post-124325.html

Need to remove the Jersey lib in the project properties.

595 Guest
Offline
Joined: 2010-11-04

Normal 0 false false false EN-GB X-NONE X-NONE MicrosoftInternetExplorer4 /*
Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal";
mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes;
mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:"";
mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm;
mso-para-margin-right:0cm; mso-para-margin-bottom:10.0pt;
mso-para-margin-left:0cm; line-height:115%; mso-pagination:widow-orphan;
font-size:11.0pt; font-family:"Calibri","sans-serif";
mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin;
mso-fareast-font-family:"Times New Roman";
mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri;
mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman";
mso-bidi-theme-font:minor-bidi;}
Hey all,

I'm teaching myself Jave EE using the tutorials found on
http://download.oracle.com/javaee/ . Unfortunately I've created a problem for
myself that I seem unable to fix.

 

I have literally got to the first few steps of the "Your first cup
Application" which involved setting up a web application and creating a page
that says "15" and this is the error I am getting:

 

>*description *The server encountered an internal error () that prevented it
>from fulfilling this request.
>
>*exception*
>
>javax.servlet.ServletException: PWC1391: Servlet.init() for servlet
>org.netbeans.rest.application.config.ApplicationConfig threw exception
>
>*root cause*
>
>com.sun.jersey.api.container.ContainerException: The ResourceConfig instance
>does not contain any root resource classes.
>
 

This error occurred when I refectories my only class from DukesAgeREsource
to DukesAgeResource. I've restarted the project under a different name and it
works fine, but if I delete the original project and create one of the same
name the same error will appear. This makes me think it's something to
do with a file related to the Glassfish server, but I have no idea really
since I am just starting out!

I have done some searching and heard that it can be an error with a servlets
being created, I've checked the sun-web.xml files and this doesn't seem
the case. I have compared most files with a working new project and they seem
identical in every way so I am at a lost for solutions.

 

Any help is appreciated.