Skip to main content

[JAI-IMAGEIO] Decoding issues with pure-Java JIIO J2K ImageReader

3 replies [Last post]
Anonymous

Hi all.

I am here once again to report decoding issues related to JIIO J2K
ImageReaders.

Recently, I reported some decoding issues with the NATIVE JIIO J2K
ImageReader. A related bug was then submitted by someone on the list:

https://jai-imageio-core.dev.java.net/issues/show_bug.cgi?id=189

Following to the discovery of those issues, we switched to the PURE-JAVA
JIIO J2K ImageReader in our application, which is a bit slower but seemed to
work better.

But now, I am encountering some "decoding issues / artifacts" also with the
pure-Java J2K ImageReader. Please see the images contained in the following
ZIP archive:

http://demo.neologica.it/JIIO_J2KImageReader_Test2.zip

As you can see, in this case the native J2K Image Reader seems to work fine,
but the pure-Java version doesn't.

In other cases, it is the opposite.

Hence, which J2K ImageReader shall we use??? :-(

Do you have suggestions or workarounds to these decoding issues?

Thanks in advance and best regards,

Marco

[att1.html]

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Marco Sambin - NeoLogica

Errata corrige in my link to sample images demonstrating the issue (the text
was correct, but the link pointed to an old archive):

http://demo.neologica.it/JIIO_J2KImageReader_Test2.zip

Sorry for the inconvenience.

Regards,

Marco

From: Marco Sambin - NeoLogica [mailto:marco.sambin@neologica.it]
Sent: giovedì 23 settembre 2010 12:06
To: interest@jai-imageio.dev.java.net
Subject: [JAI-IMAGEIO] Decoding issues with pure-Java JIIO J2K ImageReader

Hi all.

I am here once again to report decoding issues related to JIIO J2K
ImageReaders.

Recently, I reported some decoding issues with the NATIVE JIIO J2K
ImageReader. A related bug was then submitted by someone on the list:


https://jai-imageio-core.dev.java.net/issues/show_bug.cgi?id=189

Following to the discovery of those issues, we switched to the PURE-JAVA
JIIO J2K ImageReader in our application, which is a bit slower but seemed to
work better.

But now, I am encountering some "decoding issues / artifacts" also with the
pure-Java J2K ImageReader. Please see the images contained in the following
ZIP archive:

http://demo.neologica.it/JIIO_J2KImageReader_Test2.zip

As you can see, in this case the native J2K Image Reader seems to work fine,
but the pure-Java version doesn't.

In other cases, it is the opposite.

Hence, which J2K ImageReader shall we use??? :-(

Do you have suggestions or workarounds to these decoding issues?

Thanks in advance and best regards,

Marco

[att1.html]

broumbroum
Offline
Joined: 2010-04-24
Points: 0

disable native !
I've always been disabling the codec libs with JIIO
[url=http://java.sun.com/products/java-media/jai/forDevelopers/jai-imageio-1_0_01-fcs-docs/index.html]as of doc[/url] [quote]If security permission settings disallow loading native code, or if the system property "com.sun.media.imageio.disableCodecLib" is set to "true" at the time of plug-in registration the native service providers will deregister themselves and the native plug-ins will not be available[/quote], because all jpeg outputs were corupted.

Message was edited by: broumbroum

Marco Sambin - NeoLogica

Hi,

thank you for your reply.

Please notice that my last post is related to a decoding issue exactly with the pure-Java J2K ImageReader (i.e., JIIO codec libs disabled).

It has also been my experience that the native JIIO J2K ImageReader has a lot of problems, and this was the reason why we switched to the pure-Java J2K ImageReader in the recent past. But unfortunately, even the pure-Java ImageReader seems to have decoding issues.

Regards,
Marco

-----Original Message-----
From: jai-imageio@javadesktop.org [mailto:jai-imageio@javadesktop.org]
Sent: giovedì 30 settembre 2010 02:54
To: interest@jai-imageio.dev.java.net
Subject: Re: RE: [JAI-IMAGEIO] Decoding issues with pure-Java JIIO J2K ImageReader

I've always been disabling the codec libs with JIIO
[url=http://java.sun.com/products/java-media/jai/forDevelopers/jai-imageio-1_0_01-fcs-docs/com/sun/media/imageio/plugins/jpeg2000/package-summary.html]as of doc[/url], because all jpeg outputs were corupted.
[Message sent by forum member 'broumbroum']

http://forums.java.net/jive/thread.jspa?messageID=483987

---------------------------------------------------------------------
To unsubscribe, e-mail: interest-unsubscribe@jai-imageio.dev.java.net
For additional commands, e-mail: interest-help@jai-imageio.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: interest-unsubscribe@jai-imageio.dev.java.net
For additional commands, e-mail: interest-help@jai-imageio.dev.java.net