Skip to main content

HDHR settings

3 replies [Last post]
rdecker
Offline
Joined: 2009-02-25

I got and HDHR unit and configured the ri per https://devzone.cablelabs.com/widget/web/ocapri/1/-/wiki/OCAP%20RI%20Pub...

RI.Platform.numTuners = 1
RI.Headend.tunerType = HDHR
RI.Headend.tuner.0.tunerNum = 0
RI.Headend.tuner.0.TunerRxPort = 4140
RI.Headend.tuner.0.StreamerPort = 0x9BB217 //hdhr

I couldn't find any udp port reference in the HDHR documentation so I left TunerRxPort as is assuming it is the port used by the RI to receive the stream from the device.

I setup a channel map with the frequency, modulation and source id matching one of the channels the found in the hdhr config scan. I get a socket error and it fails:

20100819 15:38:57.804 WARN RI.Stack- 18300 [Thread-18] WARN util.Debug -
20100819 15:38:57.804 WARN RI.Stack- java.net.SocketException: No error
at java.net.SocketInputStream.socketRead0(Native Method)
at java.net.SocketInputStream.read(SocketInputStream.java:149)
at java.io.InputStreamReader.fill(InputStreamReader.java:195)
at java.io.InputStreamReader.read(InputStreamReader.java:271)
at java.io.BufferedReader.fill(BufferedReader.java:156)
at java.io.BufferedReader.readLine(BufferedReader.java:319)
at java.io.BufferedReader.readLine(BufferedReader.java:382)
at org.cybergarage.http.HTTPPacket.set(HTTPPacket.java:137)
at org.cybergarage.http.HTTPPacket.set(HTTPPacket.java:254)
at org.cybergarage.http.HTTPPacket.set(HTTPPacket.java:259)
at org.cybergarage.http.HTTPPacket.read(HTTPPacket.java:282)
at org.cybergarage.http.HTTPRequest.read(HTTPRequest.java:349)
at org.cybergarage.http.HTTPServerThread.run(HTTPServerThread.java:46)
at java.lang.Thread.startup(Thread.java:785)
20100819 15:39:15.978 ERROR RI.HDHR.Tuner- hdhr_TunerTune -- tuning error for
Tuner0
20100819 15:39:15.978 INFO RI.DRI.Tuner- dri_TunerTune -- Returning: false
20100819 15:39:15.978 ERROR RI.UAL.ctrlpt- ControlDevice -- Error (0): (null)

20100819 15:39:15.978 WARN RI.UAL- ualCallStats -- SetTuner call duration: 2
5037ms
20100819 15:39:15.978 INFO RI.UAL- ualCallStats -- call tokens: 2/32, event
tokens: 4/32
20100819 15:39:15.978 ERROR RI.Tuner- request_tune -- unknown response data:
SetTuner = ERROR

20100819 15:39:15.978 ERROR RI.Stack- Tune request returned error! Freq=63900
0000, Mode=16, ProgNum=1. Error = 1

With debug logging I get:

20100819 15:53:46.410 INFO RI.DRI.Tuner- dri_SetTuner -- 127.0.0.1:4140
20100819 15:54:11.042 ERROR RI.HDHR.Tuner- hdhr_TunerTune -- tuning error for
Tuner0
20100819 15:54:11.042 INFO RI.DRI.Tuner- dri_TunerTune -- Returning: false
20100819 15:54:11.042 ERROR RI.UAL.ctrlpt- ControlDevice -- Error (0): (null)

20100819 15:54:11.042 WARN RI.UAL- ualCallStats -- SetTuner call duration: 2
4632ms
20100819 15:54:11.042 INFO RI.UAL- ualCallStats -- call tokens: 2/32, event
tokens: 4/32
20100819 15:54:11.042 ERROR RI.Tuner- request_tune -- unknown response data:
SetTuner = ERROR

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
greg80303
Offline
Joined: 2008-07-03

The exception in your log is not important. It is coming from the uPnP stack used for HomeNetworking.

Double-check your StreamerPort setting. It should be set to the 32-bit Device ID on the bottom of your HDHomerun. I've never seen one with a 24-bit value like you have specified.

G

rdecker
Offline
Joined: 2009-02-25

I had two issues. I had converted the device id to hex not realizing it was already head and I didn't have RI.Platform.IpAddr set to the nic ip of my box.

Thanks for the help!

csweeney
Offline
Joined: 2009-04-11

Please review this page: https://devzone.cablelabs.com/widget/web/ocapri/1/-/wiki/OCAP%20RI%20Pub... for further details on using the HD Homerun.