Skip to main content

Application name ... is already in use.

10 replies [Last post]
glanzman
Offline
Joined: 2005-07-20
Points: 0

hi,

i tried to create a very simple jee 6 application (ear, ejb & war project) with eclipse and glassfish. If i do a Re-"Publish", the following error appears: "Application name ... is already in use. Please pick a different name.".

I would be thankful for any help in this issue.

Eclipse Helios Java EE IDE (20100617-1415)
Oracle Glassfish Server Tools (1.6.0.201007071726)
GlassFish Server Open Source Edition 3.0.1 (build 22)
Java Version 1.6.0_21

cannot Deploy sample-ear
Deployment Error for module: sample-ear: Application name sample-ear is already in use. Please pick a different name.%%%EOL%%%java.lang.NullPointerExcep

cannot Deploy sample-ear
Deployment Error for module: sample-ear: Exception while loading the app : org.glassfish.deployment.common.DeploymentException: Error in linking security policy for sample-ear -- Inconsistent Module State%%%EOL%%%

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
ludo
Offline
Joined: 2003-06-10
Points: 0

See a possible fix via the link to a new plugin from https://glassfishplugins.dev.java.net/issues/show_bug.cgi?id=316

Let us know how it works for you...

ludo
Offline
Joined: 2003-06-10
Points: 0

Thanks for the project...
Both the web app and ejb module for me show an error when diplaying the project properties tab named deployment assembly.
The error I see in described in bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=307148

which was marked fixed, but maybe not fixed?
Can you try to open these 2 tabs to see what you see?

ludo
Offline
Joined: 2003-06-10
Points: 0

See also https://bugs.eclipse.org/bugs/show_bug.cgi?id=318068

Would it apply with what you see?

glanzman
Offline
Joined: 2005-07-20
Points: 0

hi ludo

thanks for your reply. i'm using windows xp. the error is rising if i change a file in my ear- or war-project and deploy it again with the context menu "Republish" on the glassfish server in the Servers tab. the application has to be previously configured on the server with the "Add and Remove..." context menu from the glassfish server. a change in the project will be marked like "sample-ejb [Republish]" instead of [Synchronized]. it doesn't matter if i use the automatic or manual publish operation.

you can get my exaple project and logfiles here:
http://opentickets.sourceforge.net/sandbox/sample.zip

as a workaround i can turn off autopublish and use twice "Add and Remove..." from the WTP context menu on the server instead of using "Publish". But it is a bit annoying that way.

another workaround is that one which szobi already menioned. clicking on the ear project and export the project as an EAR to the autodeploy folder.

thanks, chris

schab
Offline
Joined: 2010-08-19
Points: 0

hi,

I have the same problem.
Additional I get an "Error in linking security policy for testing -- Inconsistent Module
State" Error when undeploying the application, the same as described here: http://forums.java.net/jive/thread.jspa?threadID=76153 and https://glassfish.dev.java.net/issues/show_bug.cgi?id=11348 )

So for every change I have to stop glasshfish, delete the generated folders, undeploy application and newly deploy appication.
Thats realy annoying.

What can be the reason of this issue?

Thanks,
Christian

Message was edited by: schab

glanzman
Offline
Joined: 2005-07-20
Points: 0

After my holiday i did a fresh installation with the current version of Oracle GlassFish Server Tools (1.6.0.201008201312) which is available thru Eclipse Marketplace.
After the first test it seems, that a Re-"Publish" works well now.

ludo
Offline
Joined: 2003-06-10
Points: 0

Great to here...

We fixed a couple of issues there...So seems good so far.

ludo
Offline
Joined: 2003-06-10
Points: 0

I cannot reproduce...
Which OS are you on?
Could you attach your simple workspace?
Which exact menu do you use for "RE Publish"? By default Deploy on save is done automatically when you change something in the ejb or web project...

I see a name.%%%EOL%%%java.lang.NullPointerExcep error...
Could you also look at both the GlassFish Log File and the Eclipse Log file to see if we can get more info?

szobi
Offline
Joined: 2009-02-27
Points: 0

Hello Ludo,

Thanks for the answer!

I have swithced of the auto publish, somehow I don't like it:)

I am using a mac with snow leopard 10.6.4

There is a field in the context menu for the glassfish server on the server tab saying "Publish" I usually click on that.

Actaully I have solved the issue now by not using wtp for publishing, but clicking on the ear project and exprot the project as an EAR to the autodeploy folder. Everything works fine that way.

The project itself is a bit complex, uses GWT as frontend, and an own form handling library that depends on GWT, and gwt-dispatch. It also uses guice for server side dependency injection.

Actually I have already planned to create a skeleton project that new projects can fork from. I will test this issue with that, and if the problem exists I will post it here with the code.

szobi
Offline
Joined: 2009-02-27
Points: 0

I have the very same issue. Only that helps, if I remove the EAR project, stop the server, start the server, add the project, and then click on clean.

Every time when I modify something I have to go through this whole procedure. It is a bit annoying. I try to use a fresh instance of glassfish now. I'll post when it turnes out if it helps or not.

Best - Istvan