Skip to main content

not working at all ?

5 replies [Last post]
danielbreitner
Offline
Joined: 2010-06-25

Hello everybody,

I am trying (like crazy) to use the tag but it doesn´t seem to work.

I am using Tomcat 6.0.28 and Mojarra 2.0.2.

Here is an example that I just can´t get to work.
(if I understood the example right, the outputText should be rerendered when I release a key, right ? ).

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
rogerk
Offline
Joined: 2004-05-06

hmm.. that look ok to me. Can you fire up your favorite javascript debugger and see if the ajax requests are being fired?

danielbreitner
Offline
Joined: 2010-06-25

right now I don´t have one, but I will try to find one.

Did you try out that example ?

I managed to get f:ajax to work but only with event="blur".
There seems to be something wrong with the "keyup" event ...

danielbreitner
Offline
Joined: 2010-06-25

OK, Problem solved ... I think ;)

The solution was to supply an execute parameter to the ajax component, reexecuting the inputText field.This helps running this example. But still I don´t know why it was not working ...






rogerk
Offline
Joined: 2004-05-06

I am not able to duplicate your problem (although I have not tried on Tomcat).
What does your managed bean look like?

danielbreitner
Offline
Joined: 2010-06-25

Well it´s pretty small :

package de.test.jsftest.ajax;

import javax.faces.bean.ManagedBean;
import javax.faces.bean.SessionScoped;

@ManagedBean
@SessionScoped
public class AjaxController {

public String text;

private String nameError;
public String getText() {
return text;
}

public void setText(String text) {
this.text = text;
}

}

What did you guys do to let it run ? Did you supply any js, and additional libs ?