Skip to main content

JAX WS jar dependancy issue in WAS 6 server

No replies
vamshi_posts
Offline
Joined: 2010-06-14
Points: 0

Hi Friends,
I am facing with the below exception when i try to run my application. My web service client is using the jaxws 2.1 jars. The whole application is deployed in Web Sphere Application Server (WAS 6) which is jdk 1.5 compliant when i try to access the service i face the below exception.

Is the jaxws 2.1 jar compliant with jdk 1.5, or should we use jaxws 2.0 jars.

But unlike from the above situation, i could run the application and access the service using the jboss with the same jar file.

Environment we are using are for Deployment & Execution :

1) JDK 5
2) WAS 6 server
3) Web Services (need to use JAX WS)

Jars used
---------------------------------------------------------------------
jaxb1-impl.jar
activation.jar
jaxws-api.jar
jaxws-rt.jar
jaxws-tools.jar
jsr173_api.jar
jsr181-api.jar
jsr250-api.jar
saaj-api.jar
saaj-impl.jar
sjsxp.jar
stax-ex.jar
streambuffer.jar

com.sun.xml.ws.spi.ProviderImpl.(ProviderImpl.java:88)
[6/8/10 4:46:20:269 MST] 00000043 SystemErr R at java.lang.J9VMInternals.initializeImpl(Native Method)
[6/8/10 4:46:20:269 MST] 00000043 SystemErr R at java.lang.J9VMInternals.initialize(J9VMInternals.java:194)
[6/8/10 4:46:20:269 MST] 00000043 SystemErr R at java.lang.Class.newInstanceImpl(Native Method)
[6/8/10 4:46:20:270 MST] 00000043 SystemErr R at java.lang.Class.newInstance(Class.java:1328)
[6/8/10 4:46:20:270 MST] 00000043 SystemErr R at javax.xml.ws.spi.FactoryFinder.newInstance(FactoryFinder.java:36)
[6/8/10 4:46:20:270 MST] 00000043 SystemErr R at javax.xml.ws.spi.FactoryFinder.find(FactoryFinder.java:95)
[6/8/10 4:46:20:270 MST] 00000043 SystemErr R at javax.xml.ws.spi.Provider.provider(Provider.java:83)
[6/8/10 4:46:20:270 MST] 00000043 SystemErr R at javax.xml.ws.Service.(Service.java:56)
[6/8/10 4:46:20:270 MST] 00000043 SystemErr R at

please help me with any sort of solution if u have....

Thanks in advance....