Skip to main content

Says I need Java 1.4 or later - I have Java 1.6

4 replies [Last post]
davidthi808
Offline
Joined: 2005-11-03
Points: 0

I am trying to install 1.1 and it tells me I need to have Java 1.4 or later. I have Java 1.6 installed. What do I need to do?

thanks - dave

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
davidthi808
Offline
Joined: 2005-11-03
Points: 0

Hi;

Thank you - that helps to know where they go. And suggestion on how I can get the DLLs and JARs out of the installer? Do I need to create a VM with Java 1.4 installed to install to and then copy from there to my system?

thanks - dave

Thad Humphries

Download and run the *.exe I cited in my earlier email. It will extract
everything regardless of the Java installed on your machine to the location
I described. My XP box has JRE 1.6.20 on it and it all extracted just fine.

On Thu, Jun 3, 2010 at 1:47 PM, wrote:

> Hi;
>
> Thank you - that helps to know where they go. And suggestion on how I can
> get the DLLs and JARs out of the installer? Do I need to create a VM with
> Java 1.4 installed to install to and then copy from there to my system?
>
> thanks - dave
> [Message sent by forum member 'davidthi808']
>
> http://forums.java.net/jive/thread.jspa?messageID=472629
>

--
"Hell hath no limits, nor is circumscrib'd In one self-place; but where we
are is hell, And where hell is, there must we ever be" --Christopher
Marlowe, 'Doctor Faustus' (v, 121-24)
[att1.html]

Thad Humphries

I'm a Linux developer, but I've monkeyed a bit with the Window stuff. I
*think* this should work:

Download jai_imageio-1_1-lib-windows-i586.exe from
https://jai-imageio.dev.java.net/binary-builds.html

This is an InstallShield created file. Launching in on my XP box created
C:\Program Files\Sun Microsystems\Java Advanced Imaging 1.1.3\lib with 3
jars and 3 dlls enclosed.

Now read the instructions at
http://download.java.net/media/jai-imageio/builds/release/1.1/INSTALL-ja...
Basically, the jars go in jre\lib\ext while the dlls go in jre\bin

I saw your email on the JAI list regarding JAI install. Something similar
should work there, too.

On Thu, Jun 3, 2010 at 11:31 AM, wrote:

> I am trying to install 1.1 and it tells me I need to have Java 1.4 or
> later. I have Java 1.6 installed. What do I need to do?
>
> thanks - dave
> [Message sent by forum member 'davidthi808']
>
> http://forums.java.net/jive/thread.jspa?messageID=472599
>

--
"Hell hath no limits, nor is circumscrib'd In one self-place; but where we
are is hell, And where hell is, there must we ever be" --Christopher
Marlowe, 'Doctor Faustus' (v, 121-24)
[att1.html]

Thad Humphries

Correction: The install path below is for JAI. For JAI-IMAGEIO it will be
C:\Program Files\Sun Microsystems\JAI Image IO Tools 1.1\lib with 2 jars and
3 dlls.

On Thu, Jun 3, 2010 at 12:23 PM, Thad Humphries
wrote:

> I'm a Linux developer, but I've monkeyed a bit with the Window stuff. I
> *think* this should work:
>
> Download jai_imageio-1_1-lib-windows-i586.exe from
> https://jai-imageio.dev.java.net/binary-builds.html
>
> This is an InstallShield created file. Launching in on my XP box created
> C:\Program Files\Sun Microsystems\Java Advanced Imaging 1.1.3\lib with 3
> jars and 3 dlls enclosed.
>
> Now read the instructions at
> http://download.java.net/media/jai-imageio/builds/release/1.1/INSTALL-ja...
> Basically, the jars go in jre\lib\ext while the dlls go in jre\bin
>
> I saw your email on the JAI list regarding JAI install. Something similar
> should work there, too.
>
>
> On Thu, Jun 3, 2010 at 11:31 AM, wrote:
>
>> I am trying to install 1.1 and it tells me I need to have Java 1.4 or
>> later. I have Java 1.6 installed. What do I need to do?
>>
>> thanks - dave
>> [Message sent by forum member 'davidthi808']
>>
>> http://forums.java.net/jive/thread.jspa?messageID=472599
>>
>
> --
> "Hell hath no limits, nor is circumscrib'd In one self-place; but where we
> are is hell, And where hell is, there must we ever be" --Christopher
> Marlowe, 'Doctor Faustus' (v, 121-24)
>

--
"Hell hath no limits, nor is circumscrib'd In one self-place; but where we
are is hell, And where hell is, there must we ever be" --Christopher
Marlowe, 'Doctor Faustus' (v, 121-24)
[att1.html]