Skip to main content

RI Bundle Registry not found in Eclipse

3 replies [Last post]
marvin_kim
Offline
Joined: 2007-03-21

I used eclipse-rcp-ganymede-SR2-win32.zip and used JRE 1.5.0_u22.
When I installed the plugins, I could not find "RI Bundle Registry" in the preference menu.
There is no error log in the eclipse.
Anyone has a solution for it?
Or could anyone share the working version of eclipse which include the plugins?

Message was edited by: marvin_kim

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
marvin_kim
Offline
Joined: 2007-03-21

I tried XP, Windows7, and Ubuntu.
But I get the same result.
I wonder if JRE can cause the problem.
Could you tell me the JRE version number that is working correctly?

mmillard
Offline
Joined: 2008-11-05

I use jdk1.6.0_16. Some earlier versions (like jdk 1.6.0_06) were incompatible with the TVT Framework plugins that the SDK is built on top of.

marvin_kim
Offline
Joined: 2007-03-21

Finally, I got the answer.
Thank you for the response.
The eclipse I downloaded had the following option in eclipse.ini.
-Dosgi.requiredJavaVersion=1.5
So I only used JRE 1.5, because the eclipse did not start with JRE 1.6.
Now I removed the option in eclipse.ini with JRE 1.6.0_18, I can see the menu in prefs.
Thanks mmillard,