Skip to main content

Code compatible 1.5 and 1.6

No replies
odoremieux
Offline
Joined: 2004-03-30

Hello,

I have some code that should be able to run using JDK 1.5 and JDK 1.6
I am using SwingWorker.
I would like to know if when the end user is using JDK 1.6, the code will use the SwingWorker from "javax.swing.SwingWorker" and with 1.5 "org.jdesktop.swingworker.SwingWorker".

I did try using reflection, but since SwingWorker is an abstract class, it doesn't work for me.

It's kind of a generic question. How to use some JVM specific classes.

Thanks in advance,

Olivier DOREMIEUX