Skip to main content

Migrate 0.5-dev3 to 0.5-preview3

1 reply [Last post]
sir_kusi
Offline
Joined: 2010-03-04
Points: 0

Hi there
I'm working on a Wonderland project at our university (lucerne, switzerland). We try to "upgrade" an existing wonderland 0.5-dev3 (I think, it's from august 2009) installation to version 0.5-preview3 (nightly from feb). We went into some troubles...

Q1: The world is defined in a module (as usual) and appears on the admin page. But if I mark it as "current", darkstar won't start because of an unexpected element "jme-collada-cell" in the wlc.xml. Rename "jme-collada-cell" to "collada-cell" wasn't successfully, cannot create instance of "AssetUri" from the model-tag given, the same with "model-cell". What should I do to make it working?
XXX-wlc.xml :

EtageF01

-17.600000381469727
-2.000000715255737
80.0

BOX
50.0
12.0
110.0

1.0
1.0
1.0

1.0
0.0
0.0
0.0

wla://VELabWorld/01_HTA/Trakt03_EtageF_01/models/Trakt03_EtageF_01.dae

0.0
0.0
0.0

0.001500000013038516
0.001500000013038516
0.001500000013038516

-0.9999999403953552
0.0
0.0
1.570796251296997

Q2: We have another module which has a custom cell definition, incl client/server-state-classes, renderer etc (as described in the shape-tutorial). On client side in the cellrenderer it uses the jmex.collada.colladaimporter to access a *.dae-file which is defined in the serverstate-wlc.xml. Are these dae-files supported?

Q3: When I import a KMZ-file (via dragdrop), I cant see all "objects" as when I open it in Google SketchUp. Is that the normal behavior (soory, I dont have any 3D-modelling skills)?

Q4: I liked to create a new world module. So I imported a kmz-model into the empty world, created a snapshot and copied the created files in the wonderland-snapshot-folder into my module-wfs-folder. Is this the right way?

Thanks a lot for your answers to a wonderland-newbie :-)
mark

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
maggiel
Offline
Joined: 2003-06-10
Points: 0

Mark, the Wonderland community has moved to

http://openwonderland.org/

..so bring your issue over to our new forum at

http://groups.google.com/group/openwonderland

...and folks will be glad to help out.