Skip to main content

Deployment Toolkit (deployJava.js) needs updating to support Opera 10.50

4 replies [Last post]
frankgrimes97
Offline
Joined: 2006-09-13

It looks as though Opera is *finally* using the next-generation plug-in.

However, it only seems to work when setting the user-agent string to IE or Firefox:

http://icewalker2g.wordpress.com/2010/02/19/javafx-running-in-opera-10-5...

Can someone at Oracle look into updating deployJava.js to correctly detect Opera 10.50?

Thanks,

Frank Grimes

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
frankgrimes97
Offline
Joined: 2006-09-13

FYI, I submitted an RFE at http://bugs.sun.com
If/when I get a bug ID I'll post it here.

frankgrimes97
Offline
Joined: 2006-09-13

I received an e-mail confirmation containing the following bug ID link a couple of weeks ago, but it's still not available:

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6939253

If someone from Oracle is watching these forums, could you maybe find out why it's still not visible?

Thanks,

Frank Grimes

rogerl
Offline
Joined: 2004-11-15

Hi Frank,

We are aware of the issue and looking into it.
The bug is in the system, just not visible.

-Roger
Oracle Java Development Group

frankgrimes97
Offline
Joined: 2006-09-13

The bug report is still not available for viewing.

However, I just re-tested accessing http://javafx.com with Opera 10.52 and it loads without needing to fake the user-agent string.

According to this blog post JavaFX 1.3 fixed the issue but I found nothing in the release notes which mention Opera:

http://icewalker2g.wordpress.com/2010/04/25/javafx-1-3-adds-new-features...