Skip to main content

java.lang.NullPointerException deploying an application

2 replies [Last post]
f2santos
Offline
Joined: 2010-02-23

Hi everyone!

I'm trying to migrate some projects that I had working in Tomcat to GF v3. When I try to deploy one of them I got this error message that I can't solve or find solution:

Error An error has occurred
Exception while loading the app : java.lang.Exception: java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: java.lang.IllegalArgumentException: java.lang.NullPointerException

The war I was trying to upload was made in eclipse. I've installed the GF plugin and asked to make a war with GF v3 specifications. I've also tried to upload it directly from eclipse and no success.

I've also tried to download the nightbuild from day 22 Fev and I've found the same problem.

The server.log goes as attach.

Any help?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Jan Luehe

On 02/23/10 03:00 AM, glassfish@javadesktop.org wrote:
> Hi everyone!
>
> I'm trying to migrate some projects that I had working in Tomcat to GF v3. When I try to deploy one of them I got this error message that I can't solve or find solution:
>
> [b]Error An error has occurred
> Exception while loading the app : java.lang.Exception: java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: java.lang.IllegalArgumentException: java.lang.NullPointerException[/b]
>
> The war I was trying to upload was made in eclipse. I've installed the GF plugin and asked to make a war with GF v3 specifications. I've also tried to upload it directly from eclipse and no success.
>
> I've also tried to download the nightbuild from day 22 Fev and I've found the same problem.
>
> The server.log goes as attach.
>
> Any help?
>

From your server.log, it looks like the NPE is a consequence of this error:

PWC1300: Error starting resources in context /IcaROServer: PWC4430:
Document base D:\glassfishv3\glassfish\domains\domain1\docroot\IcaROServer
does not exist or is not a readable directory

Actually, the above directory is an unusal location for an application
to be deployed to.

How exactly are you deploying your app?

Jan

> [Message sent by forum member 'f2santos' (filipe.santos@first.pt)]
>
> http://forums.java.net/jive/thread.jspa?messageID=388188
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@glassfish.dev.java.net
> For additional commands, e-mail: users-help@glassfish.dev.java.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@glassfish.dev.java.net
For additional commands, e-mail: users-help@glassfish.dev.java.net

f2santos
Offline
Joined: 2010-02-23

I was deploying it through the web interface from a remote machine.

I've tried with the command-line(local) and eclipse(remote) but I've always ended up with errors...

I've found out that if I deploy it from the same machine where GF is installed, GF identifies several classes that he cannot find ( though they are included in the war file). So I've added the missing jar in domains\domain1\lib.

I'm now stuck in

[b]Exception while loading the app : java.lang.Exception: java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: java.lang.IllegalArgumentException: java.lang.ClassNotFoundException: conf.red5.Red5Listner
[/b]
I already added the red5.jar from the project but I will look a little better for a solution.