Skip to main content

0.5 preview 3 build error

2 replies [Last post]
athabascau
Offline
Joined: 2008-07-08

Running redhat enterprise 5.4. Any thoughts?

ENV
===

$ java -version
java version "1.6.0_02"
Java(TM) SE Runtime Environment (build 1.6.0_02-b05)
Java HotSpot(TM) Client VM (build 1.6.0_02-b05, mixed mode)
$ ~/bin/apache-ant-1.8.0/bin/ant -version
Apache Ant version 1.8.0 compiled on February 1 2010
$ env | grep ANT
ANT_HOME=/home/athabascau/bin/apache-ant-1.8.0
ANT_OPTS=-XX:MaxPermSize=900m

BUILD
=====

$ ~/bin/apache-ant-1.8.0/bin/ant
Buildfile: ~/working/wonderland/0.5/0.5-preview3/wonderland/build.xml

build:

jar:

-utils-init:
[mkdir] Created dir: ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/wonderland-doclet/build/classes
[mkdir] Created dir: ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/wonderland-doclet/build/lib

-utils-compile:
[javac] ~/working/wonderland/0.5/0.5-preview3/wonderland/build-tools/build-scripts/build-setup.xml:37: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
[javac] Compiling 1 source file to ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/wonderland-doclet/build/classes

build:

-utils-jar:
[jar] Building jar: ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/wonderland-doclet/build/lib/wonderland-doclet.jar

jar:

-utils-init:
[mkdir] Created dir: ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/ant/build/classes
[mkdir] Created dir: ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/ant/build/lib

-utils-compile:
[javac] ~/working/wonderland/0.5/0.5-preview3/wonderland/build-tools/build-scripts/build-setup.xml:37: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
[javac] Compiling 1 source file to ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/ant/build/classes

build:

-utils-jar:
[jar] Building jar: ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/ant/build/lib/wonderland-ant-utils.jar

jar:

-utils-init:
[mkdir] Created dir: ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/wonderland-version/build/classes
[mkdir] Created dir: ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/wonderland-version/build/lib

-setup-subversion:

-version-get-svn:
[svn] started ...
[svn] Property 'checksum' not implemented
[svn] finished.

-version-get-failure:

-version-prepare:
[copy] Copying 1 file to ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/wonderland-version/src/classes/org/jdesktop/wonderland/utils/version

-utils-compile:
[javac] ~/working/wonderland/0.5/0.5-preview3/wonderland/build-tools/build-scripts/build-setup.xml:37: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
[javac] Compiling 1 source file to ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/wonderland-version/build/classes

build:

-utils-jar:
[jar] Building jar: ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/wonderland-version/build/lib/wonderland-version.jar

jar:
[copy] Copying 1 file to ~/working/wonderland/0.5/0.5-preview3/wonderland/utils/wonderland-version/dist

init:

unpack-core-libs:

unpack:

unpack:

unpack:

unpack:

-core-init:
[mkdir] Created dir: ~/working/wonderland/0.5/0.5-preview3/wonderland/core/build/classes
[mkdir] Created dir: ~/working/wonderland/0.5/0.5-preview3/wonderland/core/build/lib

-core-compile-common:
[javac] ~/working/wonderland/0.5/0.5-preview3/wonderland/build-tools/build-scripts/build-setup.xml:37: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
[javac] Compiling 142 source files to ~/working/wonderland/0.5/0.5-preview3/wonderland/core/build/classes
[javac] ~/working/wonderland/0.5/0.5-preview3/wonderland/core/src/classes/org/jdesktop/wonderland/common/cell/state/CellServerStateFactory.java:32: warning: [deprecation] org.jdesktop.wonderland.common.cell.state.spi.CellServerStateSPI in org.jdesktop.wonderland.common.cell.state.spi has been deprecated
[javac] import org.jdesktop.wonderland.common.cell.state.spi.CellServerStateSPI;
[javac] ^
[javac] ~/working/wonderland/0.5/0.5-preview3/wonderland/core/src/classes/org/jdesktop/wonderland/common/utils/ScannedClassLoader.java:33: warning: sun.misc.Service is Sun proprietary API and may be removed in a future release
[javac] import sun.misc.Service;
[javac] ^
[javac] ~/working/wonderland/0.5/0.5-preview3/wonderland/core/src/classes/org/jdesktop/wonderland/common/cell/state/CellServerStateFactory.java:154: warning: [deprecation] org.jdesktop.wonderland.common.cell.state.spi.CellServerStateSPI in org.jdesktop.wonderland.common.cell.state.spi has been deprecated
[javac] Iterator it2 = classLoader.getAll(
[javac] ^
[javac] ~/working/wonderland/0.5/0.5-preview3/wonderland/core/src/classes/org/jdesktop/wonderland/common/cell/state/CellServerStateFactory.java:156: warning: [deprecation] org.jdesktop.wonderland.common.cell.state.spi.CellServerStateSPI in org.jdesktop.wonderland.common.cell.state.spi has been deprecated
[javac] CellServerStateSPI.class);
[javac] ^
[javac] ~/working/wonderland/0.5/0.5-preview3/wonderland/core/src/classes/org/jdesktop/wonderland/common/utils/ScannedClassLoader.java:190: warning: sun.misc.Service is Sun proprietary API and may be removed in a future release
[javac] final Iterator providers = Service.providers(clazz, this);
[javac] ^
[javac] ~/working/wonderland/0.5/0.5-preview3/wonderland/core/src/classes/org/jdesktop/wonderland/common/cell/state/ViewComponentServerState.java:32: annotation type not applicable to this kind of declaration
[javac] @XmlTransient
[javac] ^
[javac] Note: Some input files use unchecked or unsafe operations.
[javac] Note: Recompile with -Xlint:unchecked for details.
[javac] 1 error
[javac] 5 warnings

BUILD FAILED
~/working/wonderland/0.5/0.5-preview3/wonderland/build.xml:13: The following error occurred while executing this line:
~/working/wonderland/0.5/0.5-preview3/wonderland/core/build-tools/build-scripts/core-build.xml:31: The following error occurred while executing this line:
~/working/wonderland/0.5/0.5-preview3/wonderland/build-tools/build-scripts/build-setup.xml:61: The following error occurred while executing this line:
~/working/wonderland/0.5/0.5-preview3/wonderland/build-tools/build-scripts/build-setup.xml:37: Compile failed; see the compiler error output for details.

Total time: 4 seconds
===

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
jagwire
Offline
Joined: 2008-06-21

athabascau,

It's a shot in the dark, but you might try upgrading your JRE to something more recent, I think build 18 is the latest.

http://java.sun.com/javase/downloads/index.jsp

Hope this helps,
jW

athabascau
Offline
Joined: 2008-07-08

yeah, it's builds on 18. Just tried it.