Skip to main content

SDK Rel2 install problem

3 replies [Last post]
apopv
Offline
Joined: 2009-08-14
Points: 0

Hi,

I have problems installing the latest OCAP-RI SDK in Eclipse. I followed exactly the steps in the release notes document - trying both installation options, from the update site or using a standalone installer - with no success.

Eclipse version: Ganimede (4.3.2) - using the link indicated in the release notes

SDK version: Rel2-5496

In each of the two installation options, the behavior is the same:

- no error at installation, the plugin seems to be installed correctly;

- "tru2way Workbench Feature" indeed appears in the "Installed Software" tab (Help -> Software Updates);

- all TWB files appears within Eclipse's "plugin" and "feature" folders;

but

- no feature of TWB plugins seems to work: e.g. there is no "RI Bundle Registry" entry in the Preferences window, there is no wizard for new OCAP projects, etc;

- there is no mention about TWB feature in the "About Eclipse SDK Features" window.

Any help is very much appreciated. Thanks.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
csweeney
Offline
Joined: 2009-04-11
Points: 0

Please take a look at this thread in the ocap-ri forums:
http://forums.java.net/jive/thread.jspa?threadID=72602&tstart=0

Let us know if that helps.

apopv
Offline
Joined: 2009-08-14
Points: 0

Thanks for suggestion. Unfortunately the problem still exists - I tried even with the Eclipse version from OCAP-RI SVN repository.

Below is the message I posted in the thread mentioned above, following the recommendation to check for errors in Eclipse log:

The only errors mentioned in Eclipse log are the ones below:
...
!ENTRY org.eclipse.equinox.p2.metadata.repository 2 0 2010-02-04 09:43:19.593
!MESSAGE Error parsing metadata repository
!SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2010-02-04 09:43:19.593
!MESSAGE Error at line 9, column 99: Missing required attribute in "repository": url
!SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2010-02-04 09:43:19.593
!MESSAGE Error at line 9, column 99: Illegal value for attribute "url" of element "repository": null
!SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2010-02-04 09:43:19.593
!MESSAGE Error at line 10, column 99: Missing required attribute in "repository": url
!SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2010-02-04 09:43:19.593
!MESSAGE Error at line 10, column 99: Illegal value for attribute "url" of element "repository": null
!SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2010-02-04 09:43:19.593
!MESSAGE Error at line 11, column 97: Missing required attribute in "repository": url
!SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2010-02-04 09:43:19.593
!MESSAGE Error at line 11, column 97: Illegal value for attribute "url" of element "repository": null
!SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2010-02-04 09:43:19.593
!MESSAGE Error at line 12, column 97: Missing required attribute in "repository": url
!SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2010-02-04 09:43:19.593
!MESSAGE Error at line 12, column 97: Illegal value for attribute "url" of element "repository": null
...

I checked and, indeed, in the [eclipse_home]/p2/org.eclipse.equinox.p2.metadata.repository/cache folder there are two jars which, in their content.xml file, are using "uri" as attribute name instead of "url" (those jars are created there only when TWB plugin is installed). After I replaced "uri" with "url" in those files, the error above do not appear anymore, but the TWB plugin still not working.

Any suggestions? Thanks!

mmillard
Offline
Joined: 2008-11-05
Points: 0

I haven't seen anything like this; I use the Eclipse version from the OCAP-RI SVN repository, installing it and the TWB plugins on multiple machines.

Taking a a shot in the dark: are you installing Eclipse over the same directory structure? If so, try installing the OCAP-RI SVN version in a clean directory. I'm just wondering if the cache is being picked up from a previous Eclipse installation.