Skip to main content

SAS Issues

10 replies [Last post]
shavnir
Offline
Joined: 2008-05-06
Points: 0

Hi, I recently updated to one of the recent nightly builds (rev 4330) and after soring out my .wonderland-server issues (it'd been a while since I updated) I noticed that my shared X apps have stopped working. The following appears in my Darkstar (not SAS!) log when I try and run one

java] Jan 26, 2010 4:46:57 PM org.jdesktop.wonderland.modules.sas.server.SasProviderConnectionHandler messageReceived
[java] INFO: Message received from sas provider: org.jdesktop.wonderland.modules.sas.common.SasProviderReadyMessage@cc5323
[java] Jan 26, 2010 4:46:57 PM org.jdesktop.wonderland.modules.sas.server.SasServer providerConnected
[java] INFO: Sas provider connected, clientID = org.jdesktop.wonderland.server.comms.WonderlandClientID@4665
[java] Jan 26, 2010 4:46:57 PM org.jdesktop.wonderland.modules.sas.server.SasServer providerConnected
[java] INFO: Provider added to xremwin list, clientID = org.jdesktop.wonderland.server.comms.WonderlandClientID@4665
[java] **************** Enter AppCellMOXrw.setServerState: state = [AppCellXrwServerState] org.jdesktop.wonderland.common.cell.state.ViewComponentServerState@13b23eb[BasicCellSetup] origin=(0.0,2.2470951E-5,0.0) rotation=(0.0,0.0,0.0) @ 1.0 scaling=(1.0,1.0,1.0) bounds=SPHERE@1.0, 1.0 1.0 [App2DCellServerState]: pixelScaleX=0.01,pixelScaleY=0.01 [AppConventionalCellServerState]: appName=ff,launchLocation=server,launchUser=null,isBestView=false,command=null [AppCellXrwServerState]
[java] Jan 26, 2010 4:47:54 PM org.jdesktop.wonderland.modules.appbase.server.cell.App2DCellMO setServerState
[java] INFO: vcss = org.jdesktop.wonderland.common.cell.state.ViewComponentServerState@13b23eb
[java] Jan 26, 2010 4:47:54 PM org.jdesktop.wonderland.modules.appbase.server.cell.App2DCellMO setServerState
[java] INFO: Cell creator view transform = [tx=0.0 ty=2.2470951E-5 tz=0.0] [rot=com.jme.math.Vector3f [X=1.0, Y=0.0, Z=0.0]:0.0] [s=1.0]
[java] Jan 26, 2010 4:47:54 PM org.jdesktop.wonderland.modules.sas.server.SasServer appLaunch
[java] INFO: ***** appLaunch, command = null
[java] Jan 26, 2010 4:47:54 PM org.jdesktop.wonderland.modules.sas.server.ProviderProxy tryLaunch
[java] SEVERE: Provider tryLaunch, clientID = org.jdesktop.wonderland.server.comms.WonderlandClientID@1f19
[java] Jan 26, 2010 4:47:54 PM org.jdesktop.wonderland.modules.sas.server.ProviderProxy tryLaunch
[java] SEVERE: command = null
[java] Jan 26, 2010 4:47:54 PM org.jdesktop.wonderland.modules.sas.server.ProviderProxy tryLaunch
[java] INFO: message ID = {MessageID: -9223372036854775774}
[java] Jan 26, 2010 4:47:54 PM org.jdesktop.wonderland.server.spatial.impl.UniverseImpl createSpatialCell
[java] FINE: createSpatialCell 10 dsID 10987

This is the entirety of the SAS log :

run:
[exec] The command attribute is deprecated.
[exec] Please use the executable attribute and nested arg elements.
[exec] The command attribute is deprecated.
[exec] Please use the executable attribute and nested arg elements.
[exec] The command attribute is deprecated.
[exec] Please use the executable attribute and nested arg elements.
[exec] The command attribute is deprecated.
[exec] Please use the executable attribute and nested arg elements.
[java] Jan 26, 2010 4:46:56 PM org.jdesktop.wonderland.modules.sasxremwin.provider.SasXrwProviderMain
[java] WARNING: Connecting to server http://correct url goes here:8080/
[java] Jan 26, 2010 4:46:56 PM org.jdesktop.wonderland.common.utils.ScannedClassLoader createDB
[java] WARNING: Scanned classes in 3 ms.
[java] Jan 26, 2010 4:46:57 PM org.jdesktop.wonderland.modules.sasxremwin.provider.SasXrwProvider$SasXrwProviderSession login
[java] WARNING: Connecting XrwSecurityConnection

Any thoughts (and yes the url is set right for the SAS, I just had to edit it out :\ )

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
shavnir
Offline
Joined: 2008-05-06
Points: 0

A bit of searching lead me to yum install cairo-devel. Still getting the same error, and just to maybe help determine the problem a find -name libpixman*

[root@serc-svn run]# find / -name 'libpixman*'
/usr/share/doc/libpixman-0.1.6
/usr/lib/libpixman.so.1
/usr/lib/libpixman.so.1.0.0
/root/.wonderland-server/0.5-dev-backupnew/run/shared_application_server/run/bin/solaris/libpixman-1.so.0
/root/.wonderland-server/0.5-dev/run/shared_application_server/run/bin/solaris/libpixman-1.so.0

Did I grab the right package or am I still barking up the wrong tree?

shavnir
Offline
Joined: 2008-05-06
Points: 0

Bump for "did I get the right library"

shavnir
Offline
Joined: 2008-05-06
Points: 0

I dug around and was able to find libpixman but now I get this error when I try and jumpstart the xremwin from the .wonderland-server directory :

+ DEBUG_XS=0
+ export XREMWIN_USE_RLE=true
+ XREMWIN_USE_RLE=true
+ '[' -e /usr/share/fonts/X11 ']'
+ '[' -e /usr/share/fonts/100dpi ']'
+ '[' -e /usr/share/X11/fonts ']'
+ FP=/usr/share/X11/fonts
+ '[' -e /usr/share/X11/rgb.txt ']'
+ COARG='-co /usr/share/X11/rgb'
++ uname
+ '[' Linux == SunOS ']'
++ uname
+ '[' Linux == Linux ']'
++ uname -m
+ '[' i686 == x86_64 ']'
+ XS_PATH=bin/linux
+ XS_EXEC=Xvfb-xremwin
+ '[' 1 -gt 1 ']'
+ XS_ARGS=':2 -kb -screen 0 1600x1200x24 -remwin +extension Composite -fp /usr/share/X11/fonts/misc,/usr/share/X11/fonts/misc:unscaled,/usr/share/X11/fonts/75dpi,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/75dpi,/usr/share/X11/fonts/URW,/usr/share/X11/fonts/Speedo,/usr/share/X11/fonts/truetype,/usr/share/X11/fonts/uni:unscaled,/opt/kde3/share/fonts,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType -co /usr/share/X11/rgb'
+ XSERVER=bin/linux/Xvfb-xremwin
+ XS_CMD='bin/linux/Xvfb-xremwin :2 -kb -screen 0 1600x1200x24 -remwin +extension Composite -fp /usr/share/X11/fonts/misc,/usr/share/X11/fonts/misc:unscaled,/usr/share/X11/fonts/75dpi,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/75dpi,/usr/share/X11/fonts/URW,/usr/share/X11/fonts/Speedo,/usr/share/X11/fonts/truetype,/usr/share/X11/fonts/uni:unscaled,/opt/kde3/share/fonts,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType -co /usr/share/X11/rgb'
+ export LD_LIBRARY_PATH=:
+ LD_LIBRARY_PATH=:
+ unset XAUTHORITY
+ '[' 0 == 1 ']'
+ '[' '!' -e bin/linux/Xvfb-xremwin ']'
+ bin/linux/Xvfb-xremwin :2 -kb -screen 0 1600x1200x24 -remwin +extension Composite -fp /usr/share/X11/fonts/misc,/usr/share/X11/fonts/misc:unscaled,/usr/share/X11/fonts/75dpi,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/75dpi,/usr/share/X11/fonts/URW,/usr/share/X11/fonts/Speedo,/usr/share/X11/fonts/truetype,/usr/share/X11/fonts/uni:unscaled,/opt/kde3/share/fonts,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType -co /usr/share/X11/rgb
bin/linux/Xvfb-xremwin: error while loading shared libraries: libc.so.1: cannot open shared object file: No such file or directory

I dug around a bit and found I had a libc.so.6 but no libc.so.1

EDIT : It turned out I had the wrong libpixman-1.so.0. Is there anyone using CentOS for Wonderland that can help me figure out this library problem before I just revert back to September's build?

Message was edited by: shavnir

Ric Moore

On Mon, 2010-02-01 at 10:55 -0800, wonderland@javadesktop.org wrote:

> I dug around a bit and found I had a libc.so.6 but no libc.so.1
> [Message sent by forum member 'shavnir' (bmjohnston@bsu.edu)]

wayward4now@iam:~$ locate libc.so
/lib/libc.so.6
/lib/tls/i686/cmov/libc.so.6
/usr/lib/libc.so

Try that and see what you get... I don't have a libc.so.1 either. Just
libc.so But, wonderland works. Ric

--
My father, Victor Moore (Vic) used to say:
"There are two Great Sins in the world...
..the Sin of Ignorance, and the Sin of Stupidity.
Only the former may be overcome." R.I.P. Dad.
Linux user# 44256
https://nuoar.dev.java.net/
Verizon Cell # 434-774-4987

shavnir
Offline
Joined: 2008-05-06
Points: 0

I tried switching the SAS's host from the FQDN to the ip : port. I get this now

[exec] The command attribute is deprecated.
[exec] Please use the executable attribute and nested arg elements.
[exec] The command attribute is deprecated.
[exec] Please use the executable attribute and nested arg elements.
[exec] The command attribute is deprecated.
[exec] Please use the executable attribute and nested arg elements.
[exec] The command attribute is deprecated.
[exec] Please use the executable attribute and nested arg elements.
[java] Jan 26, 2010 5:08:16 PM org.jdesktop.wonderland.modules.sasxremwin.provider.SasXrwProviderMain
[java] WARNING: Connecting to server http://10.4.82.149:8080/
[java] Jan 26, 2010 5:08:17 PM org.jdesktop.wonderland.common.utils.ScannedClassLoader createDB
[java] WARNING: Scanned classes in 3 ms.
[java] Jan 26, 2010 5:08:17 PM org.jdesktop.wonderland.modules.sasxremwin.provider.SasXrwProvider$SasXrwProviderSession login
[java] WARNING: Connecting XrwSecurityConnection
[java] Jan 26, 2010 5:08:17 PM org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection handleMessage
[java] WARNING: Received message from server: org.jdesktop.wonderland.modules.sas.common.SasProviderLaunchMessage@1fe8ce8
[java] Jan 26, 2010 5:08:17 PM org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection handleMessage
[java] WARNING: Received launch message from server
[java] Jan 26, 2010 5:08:17 PM org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection handleMessage
[java] WARNING: execCap = xremwin
[java] Jan 26, 2010 5:08:17 PM org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection handleMessage
[java] WARNING: appName = ff
[java] Jan 26, 2010 5:08:17 PM org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection handleMessage
[java] WARNING: command = null
[java] Jan 26, 2010 5:08:17 PM org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection handleMessage
[java] WARNING: Attempting to launch X app
[java] Jan 26, 2010 5:08:17 PM org.jdesktop.wonderland.modules.sasxremwin.provider.SasXrwProviderMain launch
[java] WARNING: Resolved command = firefox
[java] Starting X11WindowManager on display :2
[java] Escher attempting to connect to X server ...

EDIT : Switched back to the FQDN, it seems to connect to the darkstar server and then nothing else. :(

Message was edited by: shavnir

shavnir
Offline
Joined: 2008-05-06
Points: 0

Aha! If I wait a minute...I get a stack trace.

[exec] The command attribute is deprecated.
[exec] Please use the executable attribute and nested arg elements.
[exec] The command attribute is deprecated.
[exec] Please use the executable attribute and nested arg elements.
[java] Jan 27, 2010 9:56:17 AM org.jdesktop.wonderland.modules.sasxremwin.provider.SasXrwProviderMain
[java] WARNING: Connecting to server http://url here:8080/
[java] Jan 27, 2010 9:56:19 AM org.jdesktop.wonderland.common.utils.ScannedClassLoader createDB
[java] WARNING: Scanned classes in 3 ms.
[java] Jan 27, 2010 9:56:19 AM org.jdesktop.wonderland.client.login.ProgrammaticLogin login
[java] WARNING: Darkstar server not available. Retrying every 5 seconds.
[java] Jan 27, 2010 9:56:25 AM org.jdesktop.wonderland.modules.sasxremwin.provider.SasXrwProvider$SasXrwProviderSession login
[java] WARNING: Connecting XrwSecurityConnection
[java] Jan 27, 2010 9:56:25 AM org.jdesktop.wonderland.client.login.ProgrammaticLogin login
[java] WARNING: Connected to Darkstar server.
[java] Jan 27, 2010 9:59:39 AM org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection handleMessage
[java] WARNING: Received message from server: org.jdesktop.wonderland.modules.sas.common.SasProviderLaunchMessage@b32ed4
[java] Jan 27, 2010 9:59:39 AM org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection handleMessage
[java] WARNING: Received launch message from server
[java] Jan 27, 2010 9:59:39 AM org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection handleMessage
[java] WARNING: execCap = xremwin
[java] Jan 27, 2010 9:59:39 AM org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection handleMessage
[java] WARNING: appName = ff
[java] Jan 27, 2010 9:59:39 AM org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection handleMessage
[java] WARNING: command = null
[java] Jan 27, 2010 9:59:39 AM org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection handleMessage
[java] WARNING: Attempting to launch X app
[java] Jan 27, 2010 9:59:39 AM org.jdesktop.wonderland.modules.sasxremwin.provider.SasXrwProviderMain launch
[java] WARNING: Resolved command = /usr/bin/firefox
[java] Starting X11WindowManager on display :2
[java] Escher attempting to connect to X server ...
[java] Attempt to connect to X server timed out after 60 seconds
[java] Jan 27, 2010 10:00:39 AM org.jdesktop.wonderland.modules.xremwin.client.wm.X11IntegrationModule initialize
[java] SEVERE: X Window Manager creation failed:
[java] java.lang.Error: Failed to create socket: java.io.IOException: Cannot connect to X server
[java] at gnu.x11.Connection.(Connection.java:183)
[java] at gnu.x11.Display.(Display.java:212)
[java] at gnu.x11.Display.(Display.java:187)
[java] at gnu.x11.Application.(Application.java:53)
[java] at gnu.x11.Application.(Application.java:37)
[java] at org.jdesktop.wonderland.modules.xremwin.client.wm.X11WindowManager.(X11WindowManager.java:143)
[java] at org.jdesktop.wonderland.modules.xremwin.client.wm.X11IntegrationModule.initialize(X11IntegrationModule.java:50)
[java] at org.jdesktop.wonderland.modules.xremwin.client.WindowSystemXrw.startWindowManager(WindowSystemXrw.java:165)
[java] at org.jdesktop.wonderland.modules.xremwin.client.WindowSystemXrw.(WindowSystemXrw.java:116)
[java] at org.jdesktop.wonderland.modules.xremwin.client.WindowSystemXrw.create(WindowSystemXrw.java:96)
[java] at org.jdesktop.wonderland.modules.xremwin.client.AppXrwMaster.(AppXrwMaster.java:132)
[java] at org.jdesktop.wonderland.modules.sasxremwin.provider.SasXrwProviderMain.launch(SasXrwProviderMain.java:189)
[java] at org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection.handleMessage(SasProviderConnection.java:91)
[java] at org.jdesktop.wonderland.client.comms.BaseConnection.messageReceived(BaseConnection.java:125)
[java] at org.jdesktop.wonderland.client.comms.WonderlandSessionImpl$ClientRecord.handleMessage(WonderlandSessionImpl.java:1002)
[java] at org.jdesktop.wonderland.client.comms.WonderlandSessionImpl.fireSessionMessageReceived(WonderlandSessionImpl.java:489)
[java] at org.jdesktop.wonderland.client.comms.WonderlandSessionImpl$WonderlandClientListener.receivedMessage(WonderlandSessionImpl.java:785)
[java] at com.sun.sgs.client.simple.SimpleClient$SimpleClientConnectionListener.handleSessionMessage(SimpleClient.java:601)
[java] at com.sun.sgs.client.simple.SimpleClient$SimpleClientConnectionListener.handleApplicationMessage(SimpleClient.java:482)
[java] at com.sun.sgs.client.simple.SimpleClient$SimpleClientConnectionListener.receivedMessage(SimpleClient.java:442)
[java] at com.sun.sgs.impl.client.simple.SimpleClientConnection.bytesReceived(SimpleClientConnection.java:170)
[java] at com.sun.sgs.impl.io.SocketConnection.filteredMessageReceived(SocketConnection.java:144)
[java] at com.sun.sgs.impl.io.CompleteMessageFilter.processReceiveBuffer(CompleteMessageFilter.java:138)
[java] at com.sun.sgs.impl.io.CompleteMessageFilter.filterReceive(CompleteMessageFilter.java:103)
[java] at com.sun.sgs.impl.io.SocketConnectionListener.messageReceived(SocketConnectionListener.java:128)
[java] at org.apache.mina.common.support.AbstractIoFilterChain$TailFilter.messageReceived(AbstractIoFilterChain.java:703)
[java] at org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(AbstractIoFilterChain.java:362)
[java] at org.apache.mina.common.support.AbstractIoFilterChain.access$1100(AbstractIoFilterChain.java:54)
[java] at org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceived(AbstractIoFilterChain.java:800)
[java] at org.apache.mina.filter.executor.ExecutorFilter.processEvent(ExecutorFilter.java:247)
[java] at org.apache.mina.filter.executor.ExecutorFilter$ProcessEventsRunnable.run(ExecutorFilter.java:307)
[java] at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
[java] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
[java] at java.lang.Thread.run(Thread.java:619)
[java] java.lang.RuntimeException: X Window Manager creation failed: java.lang.Error: Failed to create socket: java.io.IOException: Cannot connect to X server
[java] at org.jdesktop.wonderland.modules.xremwin.client.wm.X11IntegrationModule.initialize(X11IntegrationModule.java:54)
[java] at org.jdesktop.wonderland.modules.xremwin.client.WindowSystemXrw.startWindowManager(WindowSystemXrw.java:165)
[java] at org.jdesktop.wonderland.modules.xremwin.client.WindowSystemXrw.(WindowSystemXrw.java:116)
[java] at org.jdesktop.wonderland.modules.xremwin.client.WindowSystemXrw.create(WindowSystemXrw.java:96)
[java] at org.jdesktop.wonderland.modules.xremwin.client.AppXrwMaster.(AppXrwMaster.java:132)
[java] at org.jdesktop.wonderland.modules.sasxremwin.provider.SasXrwProviderMain.launch(SasXrwProviderMain.java:189)
[java] at org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection.handleMessage(SasProviderConnection.java:91)
[java] at org.jdesktop.wonderland.client.comms.BaseConnection.messageReceived(BaseConnection.java:125)
[java] at org.jdesktop.wonderland.client.comms.WonderlandSessionImpl$ClientRecord.handleMessage(WonderlandSessionImpl.java:1002)
[java] at org.jdesktop.wonderland.client.comms.WonderlandSessionImpl.fireSessionMessageReceived(WonderlandSessionImpl.java:489)
[java] at org.jdesktop.wonderland.client.comms.WonderlandSessionImpl$WonderlandClientListener.receivedMessage(WonderlandSessionImpl.java:785)
[java] at com.sun.sgs.client.simple.SimpleClient$SimpleClientConnectionListener.handleSessionMessage(SimpleClient.java:601)
[java] at com.sun.sgs.client.simple.SimpleClient$SimpleClientConnectionListener.handleApplicationMessage(SimpleClient.java:482)
[java] at com.sun.sgs.client.simple.SimpleClient$SimpleClientConnectionListener.receivedMessage(SimpleClient.java:442)
[java] at com.sun.sgs.impl.client.simple.SimpleClientConnection.bytesReceived(SimpleClientConnection.java:170)
[java] at com.sun.sgs.impl.io.SocketConnection.filteredMessageReceived(SocketConnection.java:144)
[java] at com.sun.sgs.impl.io.CompleteMessageFilter.processReceiveBuffer(CompleteMessageFilter.java:138)
[java] at com.sun.sgs.impl.io.CompleteMessageFilter.filterReceive(CompleteMessageFilter.java:103)
[java] at com.sun.sgs.impl.io.SocketConnectionListener.messageReceived(SocketConnectionListener.java:128)
[java] at org.apache.mina.common.support.AbstractIoFilterChain$TailFilter.messageReceived(AbstractIoFilterChain.java:703)
[java] at org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(AbstractIoFilterChain.java:362)
[java] at org.apache.mina.common.support.AbstractIoFilterChain.access$1100(AbstractIoFilterChain.java:54)
[java] at org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceived(AbstractIoFilterChain.java:800)
[java] at org.apache.mina.filter.executor.ExecutorFilter.processEvent(ExecutorFilter.java:247)
[java] at org.apache.mina.filter.executor.ExecutorFilter$ProcessEventsRunnable.run(ExecutorFilter.java:307)
[java] at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
[java] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
[java] at java.lang.Thread.run(Thread.java:619)
[java] Jan 27, 2010 10:00:39 AM org.jdesktop.wonderland.modules.xremwin.client.AppXrwMaster
[java] WARNING: Cannot launch ff 1: Cannot create window system
[java] Jan 27, 2010 10:00:39 AM org.jdesktop.wonderland.modules.sas.provider.SasProviderConnection handleMessage
[java] WARNING: connInfo = null

Message was edited by: shavnir

kaplanj
Offline
Joined: 2004-07-13
Points: 0

It looks like the X server is failing to start up. Follow the instructions in this post to run xremwin from the command line:

http://forums.java.net/jive/message.jspa?messageID=382841#382841

That should hopefully help nail down the issue. You may also want to use netstat to make sure that the server is listening to the ip address you expect -- having an IPv6 address on the server (even if it is unused) could be confusing things.

shavnir
Offline
Joined: 2008-05-06
Points: 0

When I go to start it manually I get the following

+ DEBUG_XS=0
+ export XREMWIN_USE_RLE=true
+ XREMWIN_USE_RLE=true
+ '[' -e /usr/share/fonts/X11 ']'
+ '[' -e /usr/share/fonts/100dpi ']'
+ '[' -e /usr/share/X11/fonts ']'
+ FP=/usr/share/X11/fonts
+ '[' -e /usr/share/X11/rgb.txt ']'
+ COARG='-co /usr/share/X11/rgb'
++ uname
+ '[' Linux == SunOS ']'
++ uname
+ '[' Linux == Linux ']'
++ uname -m
+ '[' i686 == x86_64 ']'
+ XS_PATH=bin/linux
+ XS_EXEC=Xvfb-xremwin
+ '[' 1 -gt 1 ']'
+ XS_ARGS=':2 -kb -screen 0 1600x1200x24 -remwin +extension Composite -fp /usr/share/X11/fonts/misc,/usr/share/X11/fonts/misc:unscaled,/usr/share/X11/fonts/75dpi,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/75dpi,/usr/share/X11/fonts/URW,/usr/share/X11/fonts/Speedo,/usr/share/X11/fonts/truetype,/usr/share/X11/fonts/uni:unscaled,/opt/kde3/share/fonts,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType -co /usr/share/X11/rgb'
+ XSERVER=bin/linux/Xvfb-xremwin
+ XS_CMD='bin/linux/Xvfb-xremwin :2 -kb -screen 0 1600x1200x24 -remwin +extension Composite -fp /usr/share/X11/fonts/misc,/usr/share/X11/fonts/misc:unscaled,/usr/share/X11/fonts/75dpi,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/75dpi,/usr/share/X11/fonts/URW,/usr/share/X11/fonts/Speedo,/usr/share/X11/fonts/truetype,/usr/share/X11/fonts/uni:unscaled,/opt/kde3/share/fonts,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType -co /usr/share/X11/rgb'
+ export LD_LIBRARY_PATH=:
+ LD_LIBRARY_PATH=:
+ unset XAUTHORITY
+ '[' 0 == 1 ']'
+ '[' '!' -e bin/linux/Xvfb-xremwin ']'
+ bin/linux/Xvfb-xremwin :2 -kb -screen 0 1600x1200x24 -remwin +extension Composite -fp /usr/share/X11/fonts/misc,/usr/share/X11/fonts/misc:unscaled,/usr/share/X11/fonts/75dpi,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/75dpi,/usr/share/X11/fonts/URW,/usr/share/X11/fonts/Speedo,/usr/share/X11/fonts/truetype,/usr/share/X11/fonts/uni:unscaled,/opt/kde3/share/fonts,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType -co /usr/share/X11/rgb
bin/linux/Xvfb-xremwin: error while loading shared libraries: libpixman-1.so.0: cannot open shared object file: No such file or directory

My netstat does list a pair of ipv6s for the Foreign Address in the Active Internet connections (w/o servers) header. I'm afraid I'm a bit rusty on Linux...is there any way to change 'em back to ipv4?

edit : I'm apparently bad at netstat too, that was my ssh connection in >_>. No other IPv6, everything else is using the fully qualified domain name instead.

Message was edited by: shavnir

kaplanj
Offline
Joined: 2004-07-13
Points: 0

OK, looks like a simple missing library problem. What version of Linux are you using? If it is ubuntu or debian based, you can just do "sudo apt-get install libpixman-1-0" to get the library you are missing.

shavnir
Offline
Joined: 2008-05-06
Points: 0

I'm in CentOS. This wasn't a problem until I updated from a relatively older build...did you guys change library requirements recently-ish?