Skip to main content

class not found exception in axis2

2 replies [Last post]
vkpandit
Offline
Joined: 2009-09-07
Points: 0

I am using Axis2.1.5 and axis 2 eclipse plugin for service generator.
I am including all the jar files for the imported classes for the creation of the aar file and deploying the aar file in axis2. However, I get a Class Not Found Exception at runtime even though the jar files are included in the aar file. Anyone know what the problem is or how I can fix it?

Thanks,

Sonia

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
abc2009
Offline
Joined: 2009-09-22
Points: 0

Try yahoo or google search or try your fortune in library.

http://www.sharewareguides.com/ has "software development" area, you can have a see whether there's a related guide book.

sarobenalt
Offline
Joined: 2005-01-01
Points: 0

The ClassNotFoundException is probably the result of a missing class in the hierarchy of required classes for your application. In other words, although the requested class exists in your aar, it depends on a class that should be somewhere in your classpath, but can't be located.

Since the classpath may vary between different containers, there's not a simple answer to the solution for your problem. It's always good to verify that your Axis installation is complete (via the admin console). And you should also verify that any supporting jars your application depends on are available in the WEB-INF/lib folder, along with the axis jars.

Hope that helps.
Steve Robenalt