Skip to main content

feature MR4 build error

5 replies [Last post]
gaganmalik
Offline
Joined: 2008-06-11
Points: 0

Hi,

I was trying to build the MR4 release for windows i386 and getting the following error in the last step - for building "phoneME Feature Software Reference Port"

make[1]: Entering directory `C:/my/projects/vaporizer/mr4/phoneme_feature/midp/build/javacall'
... searching updated .java files
make[1]: *** No rule to make target `C:/my/projects/vaporizer/mr4_emulator/phoneme-lib/odd.jar', needed by `C:/my/projects/vaporizer/mr4/build_output/midp/classes.zip'. Stop.
make[1]: Leaving directory `C:/my/projects/vaporizer/mr4/phoneme_feature/midp/build/javacall'
make: *** [build_classes] Error 2
make: Leaving directory `C:/my/projects/vaporizer/mr4/phoneme_feature/midp/build/javacall'

Everything else has built fine..
Any help is appreciated..

Thanks

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
yevgenydiomidov
Offline
Joined: 2006-08-07
Points: 0

Hi,

Have you download and unzip "emulator binary file" as described there: https://phoneme.dev.java.net/content/mr4/download_feature.html ?

gaganmalik
Offline
Joined: 2008-06-11
Points: 0

yes I have..
:(

gaganmalik
Offline
Joined: 2008-06-11
Points: 0

I'm using Visual Studio 2005 and here are my build scripts:

call "C:\Program Files\Microsoft Visual Studio 8\Common7\Tools\vsvars32.bat"
REM call "C:\Program Files\Microsoft Visual Studio\VC98\Bin\VCVARS32.BAT"
set VAPORIZER=C:/my/projects/vaporizer
set MEHOME=%VAPORIZER%/mr4/phoneme_feature
set COMPONENTS_DIR=%VAPORIZER%/mr4/phoneme_feature
set EMULATOR_DIR=%VAPORIZER%/mr4_emulator
set BUILD_OUTPUT_DIR=%VAPORIZER%/mr4/build_output
set JDK_DIR=C:/PROGRA~1/Java/JDK16~1.0_1
set CYG4ME=C:\cyg4me
set PATH=%JDK_DIR%/bin;%CYG4ME%\bin;%PATH%
set BuildDir=%MEHOME%/javacall-com/configuration/phoneMEFeature/win32_emul

build1:
make -C %BuildDir% JAVACALL_DIR=%MEHOME%/javacall PROJECT_JAVACALL_DIR=%MEHOME%/javacall-com JAVACALL_PROJECT_DIR=%MEHOME%/javacall-com JAVACALL_OUTPUT_DIR=%BUILD_OUTPUT_DIR%/javacall TOOLS_DIR=%MEHOME%/tools TOOLS_OUTPUT_DIR=%BUILD_OUTPUT_DIR%/tools USE_OUTPUT_REDIRECTION=true USE_VS2005=true

build2:
make -C %MEHOME%/pcsl PCSL_PLATFORM=javacall_i386_vc PCSL_OUTPUT_DIR=%BUILD_OUTPUT_DIR%/pcsl JAVACALL_OUTPUT_DIR=%BUILD_OUTPUT_DIR%/javacall TOOLS_DIR=%MEHOME%/tools TOOLS_OUTPUT_DIR=%BUILD_OUTPUT_DIR%/tools USE_VS2005=true

build3:
set JVMWorkSpace=%MEHOME%/cldc
make -C %JVMWorkSpace%/build/javacall_i386_vc JVMBuildSpace=%BUILD_OUTPUT_DIR%/cldc ENABLE_PCSL=true PCSL_OUTPUT_DIR=%BUILD_OUTPUT_DIR%/pcsl JAVACALL_OUTPUT_DIR=%BUILD_OUTPUT_DIR%/javacall TOOLS_DIR=%MEHOME%/tools TOOLS_OUTPUT_DIR=%BUILD_OUTPUT_DIR%/tools ENABLE_JAVA_DEBUGGER=true ENABLE_MULTIPLE_PROFILES_SUPPORT=true USE_VS2005=true

build4:
make -C %MEHOME%/midp/build/javacall MIDP_OUTPUT_DIR=%BUILD_OUTPUT_DIR%/midp PCSL_OUTPUT_DIR=%BUILD_OUTPUT_DIR%/pcsl CLDC_DIST_DIR=%BUILD_OUTPUT_DIR%/cldc/javacall_i386_vc/dist JAVACALL_OUTPUT_DIR=%BUILD_OUTPUT_DIR%/javacall TOOLS_DIR=%MEHOME%/tools TOOLS_OUTPUT_DIR=%BUILD_OUTPUT_DIR%/tools JAVACALL_PLATFORM=win32_i386_vc USE_ON_DEVICE_DEBUG=true USE_JAVA_DEBUGGER=true PRECOMPILED_ODD=true ODD_JAR=%EMULATOR_DIR%/phoneme-lib/odd.jar USE_VS2005=true

the build 4 is failing with the error I've posted above..

gaganmalik
Offline
Joined: 2008-06-11
Points: 0

anyone??

gaganmalik
Offline
Joined: 2008-06-11
Points: 0

RESOLVED!
it was a configuration error in one of my environment variables..

thanks!!