Skip to main content

update 1.6 b14 jdic not working anymore

3 replies [Last post]
taylans
Offline
Joined: 2008-08-18

1.6 u13 everything ok
1.6 u14 jdic browser not working anymore. no exceptions. both as standalone appl. and jnlp.
only gray area instead of browser content. can it be related to bugfix:

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6779670

or

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6776743

?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
davidson1
Offline
Joined: 2003-06-25

I have resolved my problem related to this issue. We are inserting our Browser component in a layered pane (actually a JXLayer) so we were impacted by the LW/HW mixing algorithm changes.

We were using a GlassPane type mechanism to disable the some features and to put up a "blank screen" while the page was built, deployed and rendered in the IWebBrowser.

My solution was to call getGlassPane().setVisible(false) when we no longer required the services of JXLayer. I would then set it to visible when we required it again.

taylans
Offline
Joined: 2008-08-18

hi

i faced this problem on jtabbedpanes. to solve the problem i set the property

sun.awt.disableMixing to true.

but this property does not take effect when using from jnlp. it works when run as an jar application.

the problem with jnlp is another java bug. this property must play role before classloading but when using jnlp there are some problems. this bug will be solved on update 17. it is listed as a bug in release 16.

Message was edited by: taylans

davidson1
Offline
Joined: 2003-06-25

I'm facing this problem on Windows. Did you ever get a resolution on this issue? I'm in the process of investigating this.