Skip to main content

javax.swing.GroupLayout

2 replies [Last post]
kevin13
Offline
Joined: 2009-05-07
Points: 0

Hi,

I get a missing package error when compiling the BridgeHeadDiscImage/Client Xlet - package java.swing.GroupLayout does not exist. All of the other swing elements compile fine. Does this need to be compiled with JAVA 1.6? I thought BD-J is limited to 1.3?

thanks

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
chihiro_saito
Offline
Joined: 2006-11-08
Points: 0

I guess GroupLayout does make that portion require jdk 1.6, instead of 1.5 or below. To tell you the truth, I developed that UI using Netbean's Swing GUI builder (former Matisse) instead of writing the code directly myself.

BD-J APIs are 1.3 based, true, but the client portion of the Bridgehead is expected to be executed on a desktop machine running jdk.

Chihiro

kevin13
Offline
Joined: 2009-05-07
Points: 0

That makes sense now,

Thanks Chihiro.