Skip to main content

Is there a small problem with AWT Menus with pMEA PP WM6 ?

1 reply [Last post]
t56
Offline
Joined: 2009-03-11
Points: 0

Hi all,
I'm having a small problem with an AWT application using phoneME Advanced Personal Profile for Windows Mobile 6 and was wondering if anyone came across it before. All works fine, but when I click on the 11th MenuItem, it doesn't execute my application code, but brings up a popup menu with "Appointment, Contact, Message, Note and Task" in it. I can select any of these and it brings up the relevant Windows Mobile application. No good for my application though (although some would describe it as a feature). Subsequent MenuItems are fine, i.e. the 12th, 13th etc.

I rearranged the menus, but the 11th one always displays this popup, so it's not a hidden escape character in my code. Anyway, I placed a dummy 11th MenuItem into my application just to have my stuff working so there's no panic on this one.

I noticed at http://www.cs.kuleuven.be/~davy/phoneme/?q=node/14 that there was a known bug wrt AWT menus, and this was fixed. The example shown (bug 14) though has 10 menuitems, so possibly there's another one lurking.

Anyway, I was just wondering if anyone came across it before.
Thanks, John.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
davyp
Offline
Joined: 2007-01-03
Points: 0

I have noticed a similar problem too. I am not sure, but I think the window message of the
11th MenuItem is (by accident) mapped onto an existing one that triggers the popup menu.
I will look into it.

Davy