Skip to main content

Is PhoneME supported on Linux/x86 now?

2 replies [Last post]
Joined: 2005-12-17


I'm new here. I read the PhoneME project and I'm very interested for more investigation of it. From the document, currently the features can only be built on Linux/ARM platform, so I wonder if there is a solution for Linux/x86 user? I'm working on Linux/x86 (Debian) system, and being lazy to install another Windows system unless really necessary.

Thanks very much.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Joined: 2009-03-30

I've tried to compile PhoneME on Linux/x86 accroding to the document for Linux/arm. The vm can work and show "Hello world" in the screen. But the runMidlet binary in midp cann't work.
Now I'm reading the source file and trying to find out where the problem is. The work seems different to me. So, is there anyone who can help me. Thank you! Also, welcome to discuss with me about this.

Joined: 2006-10-16

Generally, it should work. Despite we don't support this configuration officially it should be functional. What problem did you face?