Skip to main content

Dependency on Java 1.4.x SDK

No replies
ebresie
Offline
Joined: 2003-08-06
Points: 0

Hey guys...

I have been trying to build the phoneME and encountered the dependency for the Java 1.4.x SDK.

While trying to get the compiler, I looked here ( http://www.sun.com/software/javaseforbusiness/getit_download.jsp ) which seems to indicate "Java Standard Edition version 1.4.2 reached its end of life in late 2008". Sun continues to provide some level of support if you are willing to pay (finally a funding source for Sun).

As there seems to be a possible End of Life issue here, is there any plans to migrate PhoneME to make use of the newer Java versions and keep in sync with them?

What specifically is the need for the dependency for 1.4.x anyway? I there a specific depreciated API?

Eric