Skip to main content

JSF 1.2_03-rc2

2 replies [Last post]
lalkmim
Offline
Joined: 2009-05-25
Points: 0

Hello all,

I'm working on a portal project using Weblogic Portal with JSF 1.2 and we are having a "tilde" problem. When any page has to renderize it, the text with the tilde gets messed up. Weblogic uses JSF 1.2_03-rc2 (JSF 1.2-b20 FCS) according to documentation. Apparently, this is the same problem as this one: https://javaserverfaces.dev.java.net/issues/show_bug.cgi?id=480

The thing is: we tried to use JSF 1.2_04, 05, 06, 07, etc and all of them gives a weird NullPointerException on RenderKitImpl.createResponseWriter. So, I imagine there are some differences between the implementations.

If anyone can give some directions on why this is occurring I'd be glad. Also, my alternative is to get this version, correct the problem, rebuild and use it. The problem with this one is that I'm not able to checkout this particular version as I don't know it's CVS path exactly.

Thanks in advance.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Ryan Lubke

On 5/26/09 9:17 AM, webtier@javadesktop.org wrote:
> Hello all,
>
> I'm working on a portal project using Weblogic Portal with JSF 1.2 and we are having a "tilde" problem. When any page has to renderize it, the text with the tilde gets messed up. Weblogic uses JSF 1.2_03-rc2 (JSF 1.2-b20 FCS) according to documentation. Apparently, this is the same problem as this one: https://javaserverfaces.dev.java.net/issues/show_bug.cgi?id=480
>
> The thing is: we tried to use JSF 1.2_04, 05, 06, 07, etc and all of them gives a weird NullPointerException on RenderKitImpl.createResponseWriter. So, I imagine there are some differences between the implementations.
>
> If anyone can give some directions on why this is occurring I'd be glad. Also, my alternative is to get this version, correct the problem, rebuild and use it. The problem with this one is that I'm not able to checkout this particular version as I don't know it's CVS path exactly.
>
Can you post the first 5 or 6 stack frames of the root case using 1.2_12?

Also, you really need to make sure that the API is upgraded along with
the implementation. If you just upgrade jsf-impl.jar strange things can
happen.
> Thanks in advance.
> [Message sent by forum member 'lalkmim' (lalkmim)]
>
> http://forums.java.net/jive/thread.jspa?messageID=347707
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: webtier-unsubscribe@glassfish.dev.java.net
> For additional commands, e-mail: webtier-help@glassfish.dev.java.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: webtier-unsubscribe@glassfish.dev.java.net
For additional commands, e-mail: webtier-help@glassfish.dev.java.net

lalkmim
Offline
Joined: 2009-05-25
Points: 0

Thanks for answering mate.

In fact, we already solved the problem. We implemented a new view handler and appointed it on faces-config.xml. It's source code was identical to 1.2_03's version of ViewHandlerImpl.java + the 480 issue bug fix. It's been working great so far.

I hope this can help others with similar incompatibility issues.