Skip to main content

Problems in JavaTV SDK installation: Error initializing DirectSound

2 replies [Last post]
brunogh
Offline
Joined: 2006-04-23
Points: 0

Hello,

I followed the steps provided at https://javatv-developers.dev.java.net/servlets/ProjectProcess?tab=1 and could not run the default wizard demo app on NetBeans 6.5.1 and Windows XP. Seems to be something related to DirectX? Any suggestions?

Here is the log:

pre-init:
pre-load-properties:
exists.config.active:
exists.netbeans.user:
exists.user.properties.file:
load-properties:
exists.platform.active:
exists.platform.configuration:
exists.platform.profile:
basic-init:
cldc-pre-init:
cldc-init:
cdc-init:
ricoh-pre-init:
ricoh-init:
semc-pre-init:
semc-init:
savaje-pre-init:
savaje-init:
sjmc-pre-init:
sjmc-init:
nokiaS80-pre-init:
nokiaS80-init:
nsicom-pre-init:
nsicom-init:
Calling BD-J init
bdj-init:
post-init:
init:
conditional-clean-init:
conditional-clean:
deps-jar:
pre-preprocess:
do-preprocess:
Pre-processing 0 file(s) into C:\Documents and Settings\bcg\Desktop\teste_app\CdcApplication2\build\preprocessed directory.
post-preprocess:
preprocess:
pre-compile:
extract-libs:
do-compile:
post-compile:
compile:
pre-obfuscate:
proguard-init:
skip-obfuscation:
proguard:
post-obfuscate:
obfuscate:
pre-preverify:
do-preverify:
post-preverify:
preverify:
pre-jar:
set-password-init:
set-keystore-password:
set-alias-password:
set-password:
create-jad:
do-extra-libs:
nokiaS80-prepare-j9:
nokiaS80-prepare-manifest:
nokiaS80-prepare-manifest-no-icon:
nokiaS80-create-manifest:
semc-build-j9:
do-jar:
nsicom-create-manifest:
do-jar-no-manifest:
bdj-build-image:
update-jad:
ricoh-init-dalp:
ricoh-add-app-icon:
ricoh-build-dalp-with-icon:
ricoh-build-dalp-without-icon:
ricoh-build-dalp:
savaje-prepare-icon:
savaje-build-jnlp:
post-jar:
jar:
pre-run:
cldc-run:
ricoh-run:
semc-icon-assembly:
semc-ppro-emulator:
semc-do-run:
semc-run:
savaje-run:
sjmc-run:
@@XletRunner starting Xlet cdcapplication2.Main
null
SimpleXlet: initXlet called
SimpleXlet: startXlet called
Error initializing DirectSound DirectSoundCreate8 == NULL
nokiaS80-run:
nsicom-run:
bdj-run:
run:
CONSTRUÍDO COM SUCESSO (tempo total: 0 segundos)

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
hlavalle
Offline
Joined: 2005-06-28
Points: 0

Hi,

Did you noticed that DirectX Runtime Environment installation has 2 steps ? After extract the files, you must run the DXSETUP.exe

It is a guess (I did not try unninstall to check if the result is as the log you informed)

brunogh
Offline
Joined: 2006-04-23
Points: 0

For some reason, I have reinstalled Windows here and the steps have worked correctly. Thanks.