Skip to main content

b54 requires glibc 2.5 or later on 64 bit linux

2 replies [Last post]
parg
Offline
Joined: 2009-04-13
Points: 0

Hi,
Somewhere between b51 and b54 the installer became dependant on version 2.5 of glibc on 64 bit linux. Is this intentional?

Server details:

# uname -a
Linux 2.6.9-78.0.1.ELsmp #1 SMP Tue Jul 22 18:01:05 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

# cat /etc/redhat-release
Red Hat Enterprise Linux ES release 4 (Nahant Update 7)

thanks

....
Do you agree to the above license terms? [yes or no]
yes
Unpacking...
Checksumming...
Extracting...
./install.sfx.3651: error while loading shared libraries: requires glibc 2.5 or later dynamic linker
Failed to extract the files. Please refer to the Troubleshooting section of
the Installation Instructions on the download page for more information.

Message was edited by: parg

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
robilad
Offline
Joined: 2004-05-05
Points: 0
parg
Offline
Joined: 2009-04-13
Points: 0

Thanks.

However, I'd still like to know if this is an intentional dependency change as currently I can't install and test B54 on my managed servers due to the fact that their image is based on "Red Hat Enterprise Linux ES release 4". It is non-trivial to arrange an upgrade to 5 so it'd be good to know if there was a way to avoid doing so.