Skip to main content

glassfish plugin for eclipse update

12 replies [Last post]
bucsie
Offline
Joined: 2008-07-03
Points: 0

Hi

I have installed eclipse 3.4.2, and set up automatic updates.
I also downloaded the glassfish server adaptor some time ago, which was automatically updated several times before. Browsing the plugin info in eclipse shows the version 1.0.20 for com.sun.entreprise.jst.server.sunappsrv.

For a couple of weeks now, the automatic updates keep failing for an update of this plugin, with the error:

An error occurred while collecting items to be installed
No repository found containing: com.sun.enterprise.jst.server.sunappsrv/osgi.bundle/1.0.24
No repository found containing: com.sun.enterprise.jst.server.sunappsrv.feature/org.eclipse.update.feature/1.0.24

What is wrong with this, how can it be fixed so that the update will work again?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
jmordax
Offline
Joined: 2008-03-18
Points: 0

Well, as temporal workaround seems ok, but I think there should be a solution for the "official" installation process via WTP, shouldn't be? Most potential users will find the installation from Add Server Adapters and it is going to fail...

Anyway, thanks for the workaround.

moonbirdxp
Offline
Joined: 2009-03-24
Points: 0

I changed the update server. There is another problem:
An error occurred during the org.eclipse.equinox.internal.provisional.p2.engine.phases.CheckTrust phase.
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.CheckTrust, operand=[R]com.sun.enterprise.jst.server.sunappsrv 1.0.27 --> [R]com.sun.enterprise.jst.server.sunappsrv 1.0.28, action=).
java.lang.NullPointerException

szeldon
Offline
Joined: 2006-10-21
Points: 0

Same here. Is there any known solution for this problem?

ceefour
Offline
Joined: 2007-04-06
Points: 0
msimko
Offline
Joined: 2009-04-01
Points: 0

Having the same problem with galileo fresh install.

An error occurred while collecting items to be installed
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,com.sun.enterprise.jst.server.sunappsrv,1.0.28
No repository found containing: org.eclipse.update.feature,com.sun.enterprise.jst.server.sunappsrv.feature,1.0.28

jmordax
Offline
Joined: 2008-03-18
Points: 0

Same problem here. I opened a defect and here is the URL just in case you want to watch it: https://glassfishplugins.dev.java.net/issues/show_bug.cgi?id=196

Regards,

Chemi.

kartik_v_shah
Offline
Joined: 2004-05-31
Points: 0

To resolve this issue, just use "http://ajax.dev.java.net/eclipse" as the udpate site.

Cheers
Kartik

masrudyn
Offline
Joined: 2009-04-19
Points: 0

Hi,

How do I add that URL as the update site in Galileo? I'm using the following way to install it on Eclipse:

Preference -> Server -> Runtime Environments -> Add > Download Additional Server Adapters -> Glassfish Java EE5 EE6

There's no prompt for the URL.

When I use Help -> Install New Software and input the URL, it says no software repository.

masrudyn
Offline
Joined: 2009-04-19
Points: 0

ok I figured it out.. got it working now :-)

sburkhardt
Offline
Joined: 2009-04-11
Points: 0

wouldn't it be great if you shared your solution?

loligop
Offline
Joined: 2009-09-17
Points: 0

sburkhardt said to masrudyn: "wouldn't it be great if you shared your solution?"

Yes, it would have been nice if masrudyn had shared his solution. But I may be able to help. This worked for me:

1. Open Eclipse
2. Select 'Help -> Install New Software'
3. Add https://ajax.dev.java.net/eclipse as a new repository

Save and apply changes. Please note the use of 'https' in the URL.

darrellbrogdon
Offline
Joined: 2009-09-18
Points: 0

Worked perfectly for me. Thanks!