Skip to main content

mod_loadbalancer.so

13 replies [Last post]
mihailp
Offline
Joined: 2009-03-05

OS: Solaris 10 u3 (10_Recommended from 3.MAR.2009)
Apache 2.2.11+ aslb-9.1.1-b7

Use tutorials from:
http://blogs.sun.com/sprabhu7/entry/install_configure_lb_on_apache
http://blogs.sun.com/kshitiz/entry/load_balancer_plugin_in_glassfish

Added this to my httpd.conf:
LoadFile /usr/lib/libCstd.so.1
LoadModule apachelbplugin_module modules/mod_loadbalancer.so

config-file "/usr/local/apache-parex/conf/loadbalancer.xml"

After restart see this in error log:
[Thu Mar 05 17:53:12 2009] [notice] Initializing lbplugin BuildId: GlassFish V2.1 aslb-b07
[Thu Mar 05 17:53:14 2009] [alert] ERROR:NSS could not be initialized; The issue may be missing security DB files under /usr/local/apache22/sec_db_files; Please ensure that secmod.db, key3.db and cert7.db files are present under /usr/local/apache22/sec_db_files; Refer documentation for more details; Aborting Plugin initialization ...

WTF ?
Don't ask about permissions and existence of *.db files.

p.s.
Where i can find source of %subj% to remove NSS part from it?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
mihailp
Offline
Joined: 2009-03-05

> Let me correct myself - "There should not be much
> issues configuring and
> running it on Apache 2.2.11. "

Apache 2.2.10 the same problem here.
I'm installing Nexenta OpenSolaris to check.

Maybe you have time to troubleshoot me in private mails ? :)

Kshitiz Saxena

Load-balancer plugin is not working on opensolaris. There is already an
issue for that -
7171(https://glassfish.dev.java.net/issues/show_bug.cgi?id=7171).

Thanks,
Kshitiz

glassfish@javadesktop.org wrote:
>> Let me correct myself - "There should not be much
>> issues configuring and
>> running it on Apache 2.2.11. "
>>
>
> Apache 2.2.10 the same problem here.
> I'm installing Nexenta OpenSolaris to check.
>
> Maybe you have time to troubleshoot me in private mails ? :)
> [Message sent by forum member 'mihailp' (mihailp)]
>
> http://forums.java.net/jive/thread.jspa?messageID=335524
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@glassfish.dev.java.net
> For additional commands, e-mail: users-help@glassfish.dev.java.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@glassfish.dev.java.net
For additional commands, e-mail: users-help@glassfish.dev.java.net

mihailp
Offline
Joined: 2009-03-05

> Load-balancer plugin is not working on opensolaris.
> There is already an
> issue for that -
> 7171(https://glassfish.dev.java.net/issues/show_bug.cg
> i?id=7171).
>

Loadbalancer can't work on Solaris too.
How to check&prove it to you ?
Come on.

Kshitiz Saxena

Hi,

It is well tested on solaris 10 and it works fine. If you are willing,
we can figure it out why it is not working for you.

Thanks,
Kshitiz

glassfish@javadesktop.org wrote:
>> Load-balancer plugin is not working on opensolaris.
>> There is already an
>> issue for that -
>> 7171(https://glassfish.dev.java.net/issues/show_bug.cg
>> i?id=7171).
>>
>>
>
> Loadbalancer can't work on Solaris too.
> How to check&prove it to you ?
> Come on.
> [Message sent by forum member 'mihailp' (mihailp)]
>
> http://forums.java.net/jive/thread.jspa?messageID=335579
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@glassfish.dev.java.net
> For additional commands, e-mail: users-help@glassfish.dev.java.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@glassfish.dev.java.net
For additional commands, e-mail: users-help@glassfish.dev.java.net

mihailp
Offline
Joined: 2009-03-05

> It is well tested on solaris 10 and it works fine. If
> you are willing,
> we can figure it out why it is not working for you.
>

Ok. Thank you very much.
Let's move to the private. My email is mike.pechkin@gmail.com
I will be online monday.

Firstly, plz, send me your
1. library path string from bin/envvar
2. crle output
3. /usr/lib/mps listing

I'll keep digging at monday.

mihailp
Offline
Joined: 2009-03-05

1. i'm 100% sure i do all steps correct :)
http://blogs.sun.com/kshitiz/entry/load_balancer_plugin_in_glassfish?

2. I've tested apache2 plugin with bundled apache
3. I've tested apache2.2 plugin with compiled from scratch apache
No successfull results, the same error.

I will try 2.2.10 :)

iwarrior
Offline
Joined: 2009-03-14

I'm facing same problem,

My Server Configure is using RHEL5.3(x86) + Apache 2.2.3 + aslb-b07, I tried to use apache 2.2.10 and 2.2.11 and 2.0.63, SELINUX disabled, also got this problem. I just haven't to set the name server because the DNS not ready. I make sure the folder and file are set 777 and the folder is ready, and also make a symbolic link as cert7.db to cert8.db, Any I idea to solve this problem? My log as the below.

[Sat Mar 14 08:42:40 2009] [alert] ERROR:NSS could not be initialized; The issue may be missing security DB files under /etc/httpd/sec_db_files; Please ensure that secmod.db, key3.db and cert7.db files are present under /etc/httpd/sec_db_files; Refer documentation for more details; Aborting Plugin initialization ...
[Sat Mar 14 09:13:06 2009] [alert] --------------------Name Trans---------
[Sat Mar 14 09:13:06 2009] [alert] apache process id = 13101 ; URI = /
[Sat Mar 14 09:13:06 2009] [alert] Within apachelbplugin_name_trans()
[Sat Mar 14 09:13:07 2009] [notice] child pid 13101 exit signal Segmentation fault (11)

Kshitiz Saxena

Hi,

You can download application server with HADB from
http://developers.sun.com/appserver/downloads/index.jsp and install it.
Append /lib directory to LD_LIBRARY_PATH
in envvars script under /bin. This will ensure nss
and ssl libraries bundled with application server are picked up.

Thanks,
Kshitiz

glassfish@javadesktop.org wrote:
> I'm facing same problem,
>
> My Server Configure is using RHEL5.3(x86) + Apache 2.2.3 + aslb-b07, I tried to use apache 2.2.10 and 2.2.11 and 2.0.63, SELINUX disabled, also got this problem. I just haven't to set the name server because the DNS not ready. I make sure the folder and file are set 777 and the folder is ready, and also make a symbolic link as cert7.db to cert8.db, Any I idea to solve this problem? My log as the below.
>
> [Sat Mar 14 08:42:40 2009] [alert] ERROR:NSS could not be initialized; The issue may be missing security DB files under /etc/httpd/sec_db_files; Please ensure that secmod.db, key3.db and cert7.db files are present under /etc/httpd/sec_db_files; Refer documentation for more details; Aborting Plugin initialization ...
> [Sat Mar 14 09:13:06 2009] [alert] --------------------Name Trans---------
> [Sat Mar 14 09:13:06 2009] [alert] apache process id = 13101 ; URI = /
> [Sat Mar 14 09:13:06 2009] [alert] Within apachelbplugin_name_trans()
> [Sat Mar 14 09:13:07 2009] [notice] child pid 13101 exit signal Segmentation fault (11)
> [Message sent by forum member 'iwarrior' (iwarrior)]
>
> http://forums.java.net/jive/thread.jspa?messageID=337015
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@glassfish.dev.java.net
> For additional commands, e-mail: users-help@glassfish.dev.java.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@glassfish.dev.java.net
For additional commands, e-mail: users-help@glassfish.dev.java.net

kshitiz_saxena
Offline
Joined: 2006-05-03

Please refer to other thread for solutions provided by Mike : http://forums.java.net/jive/thread.jspa?threadID=58958

Thanks,
kshitiz

Kshitiz Saxena

Hi,

Are you using apache bundled with Solaris 10, or you have build it from
scratch?

Have you followed all steps provided in blog -
http://blogs.sun.com/kshitiz/entry/load_balancer_plugin_in_glassfish?

The load-balancer plugin is not completely open-source. Only binaries
are available.

Load-balancer plugin is well tested with Apache 2.2.10. There should be
much issues configuring and running it on Apache 2.2.11.

Thanks,
Kshitiz

glassfish@javadesktop.org wrote:
> OS: Solaris 10 u3 (10_Recommended from 3.MAR.2009)
> Apache 2.2.11+ aslb-9.1.1-b7
>
> Use tutorials from:
> http://blogs.sun.com/sprabhu7/entry/install_configure_lb_on_apache
> http://blogs.sun.com/kshitiz/entry/load_balancer_plugin_in_glassfish
>
> Added this to my httpd.conf:
> LoadFile /usr/lib/libCstd.so.1
> LoadModule apachelbplugin_module modules/mod_loadbalancer.so
>
> config-file "/usr/local/apache-parex/conf/loadbalancer.xml"
>

>
> After restart see this in error log:
> [Thu Mar 05 17:53:12 2009] [notice] Initializing lbplugin BuildId: GlassFish V2.1 aslb-b07
> [Thu Mar 05 17:53:14 2009] [alert] ERROR:NSS could not be initialized; The issue may be missing security DB files under /usr/local/apache22/sec_db_files; Please ensure that secmod.db, key3.db and cert7.db files are present under /usr/local/apache22/sec_db_files; Refer documentation for more details; Aborting Plugin initialization ...
>
> WTF ?
> Don't ask about permissions and existence of *.db files.
>
> p.s.
> Where i can find source of %subj% to remove NSS part from it?
> [Message sent by forum member 'mihailp' (mihailp)]
>
> http://forums.java.net/jive/thread.jspa?messageID=335464
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@glassfish.dev.java.net
> For additional commands, e-mail: users-help@glassfish.dev.java.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@glassfish.dev.java.net
For additional commands, e-mail: users-help@glassfish.dev.java.net

Kshitiz Saxena

Let me correct myself - "There should not be much issues configuring and
running it on Apache 2.2.11. "

Thanks,
Kshitiz

Kshitiz Saxena wrote:
> Hi,
>
> Are you using apache bundled with Solaris 10, or you have build it
> from scratch?
>
> Have you followed all steps provided in blog -
> http://blogs.sun.com/kshitiz/entry/load_balancer_plugin_in_glassfish?
>
> The load-balancer plugin is not completely open-source. Only binaries
> are available.
>
> Load-balancer plugin is well tested with Apache 2.2.10. There should
> be much issues configuring and running it on Apache 2.2.11.
>
> Thanks,
> Kshitiz

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@glassfish.dev.java.net
For additional commands, e-mail: users-help@glassfish.dev.java.net

mihailp
Offline
Joined: 2009-03-05

> Let me correct myself - "There should not be much
> issues configuring and
> running it on Apache 2.2.11. "
>

Did somebody try it under Solaris 10 ?
It even doesn't load :)

mihailp
Offline
Joined: 2009-03-05

After aborting plugin initialization apache can't handle *any* request.
I can't belive nobody use apache+glassfish loadbalancer.

Come on, make some noise.