Skip to main content

Unable to see debugger window

5 replies [Last post]
msreekanth
Online
Joined: 2006-01-31

Hi,

I have a dojo.tree widget. I am trying to use my own topic to publish.For this I used the following:

In my glue.js I have the following:

jmaki.subscribe("*onClick", function(args) {
jmaki.log("glue.js : onClick request from: " + args.widgetId);
alert("Hi");
});

jmaki.subscribe("/resultsTree",function(args) {
alert("Hi In My own listener");
if ( typeof contentValue != 'undefined' ) {
// send data back to server
}
});

notification is sent to onClick function but not for resultsTree.

I also tried debugging and changed the values of debug and debugGlue to true in jmaki.js. I don't see any degugger window.

What mistake would I have done here?Can some one please help.

Thanks,
Sreekanth

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
gmurray71
Offline
Joined: 2003-07-31

Hi Sreekanth,

Try using :

Let me know if that doesn't work.

-Greg

msreekanth
Online
Joined: 2006-01-31

Thanks Greg.

But still I see the alert message from onclick listener.I am unable to get this work.

Greg here are some more questions for you.

1)How should I make the debugger to work?
2)How to have multiple listeners to same topic?Is it possible

Thanks,
Sreekanth

msreekanth
Online
Joined: 2006-01-31

I was referring to some old blog and changed the debug options in jmaki.js instead of glue.js. Now I could see my debugger window.

So now my 2nd part of the problem still remains .

msreekanth
Online
Joined: 2006-01-31

Solved myself this one too.

Thanks everyone for reading my question.What I need to do is dig a bit deeper into docs. ;-)

sloanb
Offline
Joined: 2003-09-14

msreekanth,

Glad you were able to resolve your issues. Please don't hesitate to ask more if you face any other challenges.

Regards,
--Sloan