Skip to main content

Load Balance plugin libraries fatal error

1 reply [Last post]
relyonit
Offline
Joined: 2009-02-17

Hi, I'm installing load balance plugin on Sun Java Web Server 7.0. Once I've configured files and startup LD_LIBRARY_PATH variable to search /opt/SUNWappserver/lib/lbplugin/lib for libraries, I get a fatal error on startup:
ld.so.1: parsexml: fatal: relocation error: file /opt/SUNWwbsvr7/lib/parsexml: symbol
__RTTI__1nUEreportableException_: referenced symbol not found

Can anyone say me if there is any solution or fix to it.
I have also installed Sun Java System Application Server 9.1_01 on Solaris 10 x86-

I will appreciate so much any help on this

Regards
Victor

Also I've tried several aslb packages, currently aslb-9.1-MS4-b7.jar, previously aslb-9.1-MS4-b1.jar and aslb-9.1.1-b6.jar but in all of them I get the same error.

Message was edited by: relyonit

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
chandru_06
Offline
Joined: 2009-04-14

Dear Talents,

I need some help from yours, I didn't get any doecument for the normal java server load balancing. suppose there are 3 - 4 java server are there then how to distrubute the load between those servers.
I hope you have an idea about java application load balanceing.
Can you guide me how to load balance the java application servers. Java server TCP/UDP client server communication.
I need the load balancer which should support both TCP/UDP java services.
I tried with the LVS by specifying the service=none, but in this case java server fail safe is not supporting.

Is there any way go do the load balancer?